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Introduction 
 

About This Guide 
This Guide is intended for the employees whose duties include operating Smart Logger II Multichannel 
Call Recording and Monitoring System (hereinafter, system) and describes operation guidelines for Smart 
Logger II client application (hereinafter, application). 

This Guide refers to Smart Logger II software version 8.4. Due to ongoing system update, some 
screenshots in this Guide may differ from the actual application GUI.  

The following table shows this Guide structure. 

Section Contents 

1 Overview System purpose, features and functioning principles. 

2 Application Management Information on how to run the application, as well as how 
to log in, lock it and exit it. 

3 Application GUI Key application GUI features, including terms used in this 
Guide to define GUI elements. 

4 Working with the 
Application 

User actions required to resolve basic tasks while working 
with the application. This is the main part of the Guide. 

5 Application Settings Information on key application configuration features. 
Some configuration options that define basic actions 
within the application are also described in Section 
4 Working with the Application. 

6 Troubleshooting User actions while dealing with software issues, including 
info on how to work with system logs. 

Appendix A. Call Processing 
Scenarios 

Examples of system operating scenarios intended to 
explain rules and features of call processing within the 
system. 

Appendix B. Keyboard 
Shortcuts 

Keyboard shortcuts used while working with the system. 

Terms and Abbreviations Terms and abbreviations used in this document. 

Index Index to navigate through terms and interface elements 
referred to in this Guide. 
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In case of experiencing any issues while resolving basic tasks, please consult Section 4 Working with the 
Application. The way the information is given in this section corresponds to the steps for working with 
the application. Each subsection contains a short description of all features in question (Feature Overview 
item). Such a description is intended to quickly search for GUI elements used for specific actions within 
the application. 

In order to search information by UI commands, please refer to Index. 

 

Related Documentation 
For more in-depth information on Smart Logger II system, please refer to the following documents: 

• Smart Logger II Multichannel Call Recording and Monitoring System. System Overview. 

• Smart Logger II Multichannel Call Recording and Monitoring System. Administrator Guide. 

Technical Support 
If you have any questions concerning the use of this product, please contact Speech Technology Center’s 
technical support service or your regional dealer. 

We welcome your feedback, questions and concerns regarding Smart Logger II. 

Technical support: 

Address: STC Ltd., 4a Ul. Krasutskogo, 196084, St. Petersburg, Russia 

Phone: +7 (812) 325-88-48 

Fax: +7 (812) 327-92-97 

Email: support@speechpro.com 

Website: http://www.speechpro.ru 
 

When contacting Technical Support, please include the following details into your call/ticket: 
• Software modules/components title(s) and version(s) 
• Hardware configuration 
• Operating system title and version 
• Smart Logger II logs 
• Screenshot (a screen capture showing the way the software behaves) 
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Typographic Conventions 
The following typographic conventions are applicable to this Guide: 

 

Formatting Description 

Normal Guide body text. 

Italic Used when a term appears in the text for the first time. 

Bold Used for marking out software component names, as well as interface 
element names (headers, buttons etc.). 

Bold Italics File names and access paths. 

Monospaced blue Represents software code elements and file listings. 

Underlined blue Hyperlinks to external resources or Guide sections. 

Element > Child Command option paths are shown in the order you access a command 
button from the menu. For example, File > Exit means selecting File menu 
and then clicking Exit command. 

<label> Placeholder to be replaced with a real value. For example, in 
D:\<DirName>\file.txt <DirName> placeholder labels the file system 
directory. 

Below there is a notification layout used in the Guide according to notification severity level. 
 

 Essential requirements that are mandatory to fulfill in order to avoid critical issues. 

 

 
Possible major issues and ways of avoiding them. 

 

 
Important notes you should pay attention to. 

 

 
References to additional documents. 
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1 Overview 
 

1.1 System Purpose and Functions 
Smart Logger II multichannel call recording and monitoring system is designed to simultaneously record 
audio data coming from multiple input channels, as well as for further data processing and storing. 

Audio data sources may be represented by standard customer phone lines, both analog and digital, Е1 
lines, VoIP channels, microphones or radio and sound playing hardware line outputs. 

Smart Logger II key functions are listed below. 

1. Recording phone conversations and voice messages coming from microphones, as well as logging 
all relevant info (phone number, recording duration, etc.). Voice traffic is recorded directly into audio 
files. 

2. Maintaining a recording database (hereinafter, DB) that stores logged conversation info and 
enables searching through recordings and editing relevant data. 

3. Playing audio files using various modes, labelling recordings and processing sound signal. 

4. Agent video screen capture in the course of phone conversations, playing back the video and the 
respective audio file simultaneously. 

5. Monitoring conversations and viewing videos being logged in real time (live monitoring, live 
viewing). 

6. Storing info on call center agents, groups, departments and phone numbers. 

7. Phone conversations quality assessment using automatic and manual QM features, report 
generation based on assessment result. 

8. Integration with special call center hardware and software, which enables obtaining and storing 
additional info on phone calls (CTI integration provided by CTI Analyzer module included into the 
system). 

9. Managing audio data recording, playback and storing options, access rights and other system 
options. 
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While using Smart Logger II you are to inform the parties that conversations are 
being recorded. Before selecting a relevant method of informing you must 
consider the system configuration and specification. 
In some cases it is required to examine the network capability in order to adjust 
the feature correctly. 

System features and capabilities are defined by the modules installed as a part of the 
system. 
 

 
To view the full list of system components, please refer to Smart Logger II 
Multichannel Call Recording and Monitoring System. System Overview. 

 

1.2 System Functioning Principles 
A user accesses system features and functions using Smart Logger II application. Application installation 
and initial configuration is performed by a system administrator in the course of system software 
installation. 

Smart Logger II has a client application enabling a user to configure audio and video recording options 
and system data access settings. Phone call recording and related actions are performed by Recording 
Service and Recording Module software components installed on a Recording Station. The system may 
include several recording stations. 

 

 
Smart Logger II instances run under the system will be hereinafter referred to as 
client applications. 

Smart Logger II application enables you to perform the following functions: 

1. Managing call recording. This includes recording channel prior configuration, specifying recording 
options, viewing signal level and live monitoring. Recording channels are configured for particular 
recording stations. 

2. Working with recordings. This includes sorting and searching for recordings, displaying recording 
info, playback, etc. 

3. Searching through call center agents and phone numbers. 

4. Agent quality assessment and report generation based on its result. You may perform the 
assessment manually or create and run automatic QA tasks through QM Analyzer subsystem. 

5. Setting system and application parameters. 

6. Getting helpful information on the system and technical support. 
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Smart Logger II application works in either administrator mode which supports recording configuration 
and channel management, or in user mode supporting only database actions. You will be prompted to 
select the mode while installing the software. 

 

 
This Guide details typical tasks and actions performed in user mode. For more 
information on system admin actions (channel configuration, managing user 
accounts, handling agent and phone number list), please refer to Smart Logger II 
Multichannel Call Recording and Monitoring System. Administrator Guide. 

 

1.3 Access Right Restriction 
To restrict user access rights, as well as to prevent individuals with no relevant permissions from using 
Smart Logger II, use a built-in access right restriction system. 

Each Smart Logger II user is assigned an account (containing username and password) to work from. The 
account comes with a particular set of rights. These user rights (privileges) are defined by a system 
administrator within the application. 

To enable or disable access right restriction system, you need to have administrator privileges. When 
access right restriction is on, user authentication is required to log in. 

 

 
To learn how to configure access right restriction system, please refer to Smart 
Logger II Multichannel Call Recording and Monitoring System. Administrator 
Guide. 

There is a predefined Guest role in the system you cannot delete. This role is automatically assigned to a 
user logging in via domain authentication and not belonging to any groups relevant to Smart Logger II. 
By default, this role is not provided with any rights and/or resources. 
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2 Application Management 
 

2.1 Running the Application 
To run the application, go to Start menu and select All programs > Speech Technology Center > Smart 
Logger II > Smart Logger II. 

2.2 Logging In 
In case access right restriction system is enabled, a User login dialog will show up when you run the app 
(Fig. 1). 

 

 
To get your credentials (login and password), please consult your system 
administrator. 

 

 
To learn how to configure user accounts and database connections, please refer to 
Smart Logger II Multichannel Call Recording and Monitoring System. 
Administrator Guide. 

 

 
Figure 1: User login dialog 

In the Connection field, you can either select database server name or IP from the dropdown list or just 
enter it. The list stores the names and IP addresses you or other users have entered before. While 
connecting for the first time, the list will be empty. 

In Authorization field, select one of the following authentication methods: 

• Current Windows User: Allows you to automatically login to the application through 
current Windows user account. 
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• Smart Logger II: Use your Smart Logger II account credentials to login. 

• Windows: Use your Windows user account credentials (Domain\Username and password) 
to login. 

If you select Smart Logger II in the Authorization field, you will have to enter your user credentials as 
follows: 

Login: your system username; 

Password: your system user password. 

In case you select Current Windows User, the Login and Password fields will be grayed out (you will be 
not required to enter any credentials). 

To complete the login process, click Login. After authentication is done successfully, the startup screen 
and the application main screen will open. You may hide the startup screen by pressing Esc. 

 

2.3 Locking the Application 
When leaving your desk for a short period of time (e.g., for lunch) and in some other cases we 
recommend your locking the application. 

To lock the app, select Lock Smart Logger II from Access restriction system menu on the main screen 
(shortcut Shift+F12). The User authorization dialog, similar to User login, will appear. To unlock the 
application, enter your password. 

 

 
You can lock the application only when access right restriction is enabled (i.e., the 
Access restriction system checkbox in Access restriction system menu is 
checked). 

The application may be unlocked only by the user that has previously locked it (Fig. 2). 

 
Figure 2: User Authorization dialog 
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2.4 Changing Connection Settings 
To switch to another user account or modify connection settings, select File > Change connection 
settings in the application main menu. In the User Login dialog specify the new settings and click Login 
(Fig. 3). 

 
Figure 3: Changing connection settings 

To learn more about User Login dialog elements, please see Section 2.2 Logging In. 

 

2.5 Exiting the Application 
To exit the application, select File > Exit in the application main menu (shortcut Ctrl+Q). 
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3 Application GUI 
 

3.1 GUI Overview 
Smart Logger II application features a window-based graphical user interface with a main screen, a 
toolbar and dedicated working areas. Shortcut menus are designed to take actions within the working 
areas. 

Working with application GUI elements is mainly performed using a mouse. Keyboard shortcuts (see 
Appendix B. Keyboard Shortcuts) may be also applied to access some most frequently used menu 
options. Such shortcuts will be displayed to the right of the relevant option in the application main menu. 

You can configure working area display settings, if required. 

Apart from the main screen elements, the user interaction process is performed by means of the dialogs 
used to guide user actions. Modal dialogs work in the same way as those in other applications built for 
Windows environment. 
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3.2 Application Main Screen 
3.2.1 Main Screen Elements 
The main screen contains the GUI elements detailed on Figure 4.  

 
Figure 4: Application main screen 

1 Main screen title 

2 Main menu 

3 Toolbar 

4 Recording area 

5 Database area 

6 Player area 

7 Status bar 

The screen title (see Fig. 4) shows system name, user name (the user currently logged in) and the 
common buttons for window display settings (minimize, maximize/restore down and close). 

7 

1 
2 

3 

4 

5
 

6 
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The main menu (see Fig. 4) has some options grouped into sections according to their functions. 

The toolbar (see Fig. 4) doubles some main menu options and consists of multiple element groups. You 
can move each group within the toolbar using your mouse. 

The status bar (see Fig. 4) shows the information on the working environment status (Fig. 5). 

 
 

Figure 5: Status bar 

1 Database connection status 

2 Num Lock indicator 

3 Caps Lock indicator 

4 Insert/Overtype indicator 

You can change main screen size, position and display mode using default Windows configuration tools. 
 

3.2.2 Recording Area 
 

 
Recording area is displayed only in case you selected administrator mode when 
installing the application. If you used ClickOnce tool to install the app, the area will 
not be displayed. 

Recording area is designed to view and configure channels and recording stations. The tabs located 
within the area are described below. For more in-depth information on each tab, please refer to the 
sections specified in the Guide Sections column. 

    

Tab Purpose Short Title Guide Section 

Channels Viewing recording channel info, configuring 
channel parameters and live conversation 
monitoring. 

Channel list 4.1 

Operators Call center agent performance monitoring. Agent list 4.2 

Recording 
stations 

Viewing info on recording stations 
functioning within the system. 

Station list 4.1.2 

 

1 2 3 4 
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3.2.3 Database Area 
Database area is designed to work with recording database and view some additional info, such as news, 
events, etc. The area title displays the currently connected database name. The tabs located within the 
area are described below. For more in-depth information on each tab, please refer to the sections 
specified in the Guide Sections column. 

    

Tab Purpose 
Short Title Guide 

Sections 

Start page Access to filters and news, getting app details, 
feedback forms. 

Start page 4.4.3, 5.5, 6 

Event log Viewing and exporting info on system events. Event log  –  

Statistics Graphically visualizing logged conversation 
statistics. 

 –  4.8 

Agent 
statistics 

Viewing applications used by agents within 
specified time period 

–  –  

VIP 
customers 

Viewing and adding VIP customer details. VIP customer 
contact list 

4.7 

Screen 
capture 

Viewing agent screen video recordings. This 
feature is not supported in the current 
version.  

–  –  

Reports Report generation based on various logged 
conversation parameters. 

 –  4.9 

List <N> Viewing and editing information on the 
recordings stored in the DB, searching 
recordings, handling tasks on recording 
processing playback, evaluation, export). 
You can work with multiple recording lists; by 
default, the tab title contains (<N>) number. 
For each list, you can specify different 
operation modes, filters, display settings, etc. 

Recording list 4.3–4.5 

 

 

 
The Database area may also contain other tabs according to the modules 
installed within the system. 

 

 
For more information on working with the event log, please refer to Smart Logger 
II Multichannel Call Recording and Monitoring System. Administrator Guide. 
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3.2.4 Player Area 
Player area is designed to play back audio and video data obtained from the channels in real time mode 
(live monitoring, live video). 

For more in-depth information on player interface and functions, please refer to Section 4.6 Audio and 
Video Playback. 
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3.3 Configuring Working Areas 
To configure working areas and tabs display settings, use the View section of the application main screen 
(Fig. 6) and the buttons located in the area title. 

 
Figure 6: View section of the app main screen 

Database, Recording and Player options correspond to main screen working areas. Start page, 
Statistics and Event log options refer to the Database area tabs. 

The checkboxes on the left part of the menu define the area status: area shown (ticked) or area hidden 
(unticked). 

To show or hide an area, select it in the View section. On the right-hand part of the menu you will see the 
keyboard shortcuts you can use to quickly toggle the area status. 

Each area title has buttons shown on Figure 7. 

 
Figure 7: Area title buttons designed to configure its display settings 

Use the area title buttons to take the following actions: 

 : Open area display settings menu. 

 : Minimize area. The area will be minimized into a vertical bar with a text title. To restore the area, 
click the  button which will appear in the area title after it is minimized. 

 : Maximize area. The area will be maximized to take up the whole screen. The rest of minimizable 
areas will be minimized. To restore the original area view, click the  button which will appear in 
the area title after it is maximized. 

 : Close area. Triggers the same action as hiding an area using View section of the application 
main menu. 
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,  and  buttons are grayed out for the Player area (you cannot maximize or minimize this area). 

You can neither make an area dockable nor customize its position or size. You can only change the 
Database and Recording areas width using your mouse. 
 

3.4 Quick List Search 
To make the relevant data searching process easier, you can use the quick search. This feature is available 
for recording lists, dropdown lists when specifying filtering conditions (see Section 4.4.3) and some other 
lists. 

To run a quick search, perform the following: 

1. Make the relevant list active (e.g., by clicking any part of the list). 

2. Start typing. You will see an input box in the bottom of the list (Fig. 8). 

3. Wait for a while or press Enter. 

 
Figure 8: Quick recording search 

The search results will be displayed in the same list. Take note that the quick search is also sensitive to 
partial matches. To restore the list to its original view, click the  button to the right of the input box or 
press Esc. 
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4 Working with the Application 
 

4.1 Managing Call Recording 
4.1.1 Feature Overview 
Below there is a list of features enabling call recording management. For more in-depth information on 
each feature, please refer to the sections specified in the Guide Sections column. 

 

Feature GUI Elements 
Guide 
Sections 

Viewing recording station list Recording area > Recording stations 
tab 

4.1.2 

Viewing channel list, channel 
state recording 

Recording area > Channels tab 4.1.3 

Updating channel and station 
list 

File > Refresh channel list menu 
option/F3 key/  toolbar button 

4.1.2-4.1.4 

Channel list display settings View menu section 4.1.4 

Enabling/disabling channel 
recording, configuring 
parameters and recording 
modes 

Recording list shortcut menu (Channels 
tab, Recording area) 

4.1.5, 4.1.7 

Multichannel recording 
options 

Merge channels and Split channels 
options (available for audio files) in 
channel shortcut menu 

4.1.6 

Recording colored labeling Mark as option in channel shortcut 
menu 

4.1.7 

Live channel monitoring Double click on a channel in the channel 
list/Enable live conversation 
monitoring option in channel shortcut 
menu 

4.1.8 

Configuring live video  button in the Player area, section 
3. Live video 

4.6.6 

Playback management 
during live monitoring 

Player GUI controls 4.6.3 
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4.1.2 Viewing Recording Station List 
To view recording station list, go to Recording stations tab located in the Recording area. 

Recording station list stores info on all stations working within the system. Figure 9 shows you how this 
list looks like. 

 
Figure 9: Recording station list 

The stations are listed in a table where each row corresponds to a single station. 

Each column displays recording station properties, as below: 
 

Title Description Details 

 Recording station name Network name of the server which handles recording 
station functions. Network name is specified in the 
system configuration area. 

 Optical media storage 
support 

In case the recording station supports optical media 
storage, the field shows the  icon; otherwise, it is 
blank. 

 Fax decoding support In case the recording station supports fax decoding, 
the field shows  icon; otherwise, it is blank. 

 VoIP traffic recording 
support 

In case the recording station supports VoIP traffic 
recording, the field shows  icon; otherwise, it is 
blank. 

 Video capture support In case the recording station supports agent screen 
video capture, the field shows  icon; otherwise, it is 
blank. 

 Global repository (file 
server) 

If a server functioning as a recording station has a 
global repository, the field will show  icon; 
otherwise, it is blank. 

The left bottom part of the list contains an information list where you can see the number of recording 
stations currently functioning (e.g., there are 7 stations on Fig. 9). 
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You can customize the following list display parameters: 

1. Column order: drag and drop column titles; 

2. Column width: change it using your mouse pointer. 

 

4.1.3 Viewing Channel List 
To view the channel list, go to Channels tab located in the Recording area. 

The channel list stores info on the recording channels operating within all recording stations sharing the 
same DB. Figure 10 shows you how this list looks like. 

 
Figure 10: Channel list 

Each color highlighting each row denotes a particular channel state. The color code is explained in the 
table below. 
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Color Sample Channel State Description 

Gray  
Recording on this channel is not available (e.g., there is no 
recording station connection). 

White  
Recording on this channel is available and has been previously 
actioned. 

Orange  
Recording on this channel is available, though it has never been 
actioned before. 

Green  Recording on this channel is being currently actioned 

Red  Channel connection failed (I/O board error). 

Thus, Figure 10 shows recording on channel 7003 is unavailable, on channels 7015 to 7018 the recording 
is currently actioned and channels 1 and 2 show connection failure, while on other channels recording is 
fully available. 

Each column displays channel properties, as below: 
 

Title Description Details 

 Channel name Graphic channel type symbol and channel name. 
Channel type depends on the data source: 

 : Sound block channels. Such channel names 
will always start with Sound Block; 

 : VoIP channels. 

 Channel ID  Phone line number, Channel IP or MAC. 

 Signal level  : Active (or failed) channel signal level. In 
case no channel activity is detected or the signal is 
too low, the field is blank. 

 Audio recording channel 
operation mode 

 : Recording is enabled but not currently carried 
out. 

 : Recording is currently being carried out. 
 : Recording is paused (Pause mode). 
 : Pause command is selected but the recording 

process has not been stopped yet. 
 : Recording process is disabled. 

 Video recording channel 
operation mode 

 : Recording is enabled but not currently carried 
out. 

 : Recording is currently being carried out. 
 : Recording process is disabled. 
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Title Description Details 

 Live monitoring status If live monitoring is currently on, the  icon will 
be displayed; otherwise, the field will be blank. 

 Current recording duration Live time count. If the recording process is 
disabled, the field will display null value. 

 Call center agent (internal 
caller) phone number 

Phone number. 

 Call direction : outgoing call; 

: incoming call. 

 External caller number Phone number. 

 Agent name whose 
conversation is subject to 
recording 

Agent name. 

 Agent group name the 
agent belongs to 

Agent group name. 

 Recording station name 
the channel refers to 

Server network name. 

The left bottom part of the list contains an information list where you can see the number of selected 
channels and their total number (e.g., there is one channel selected and 28 channels overall on Fig.10). 
Besides, this area includes some additional info on the selected channel parameters. 

To update channel list, select File > Refresh channel list menu option; alternatively, you can press F3 or 
click  button located on the toolbar. During the refresh process the channel list and parameters are 
updated according to the current system state (e.g., recently registered channels are added to the list). 



Smart Logger II 
Working with the Application User Guide 

 

 27 Smart Logger II 
 

4.1.4 Configuring Channel List Display Settings 
You can customize the following list display settings: 

1. Column order: drag and drop column titles. 

2. Column width: change it using your mouse pointer. 

3. Sorting list elements by columns: click the title of the column in question. 

4. Channel list sorting parameters: 

• Sorting by recording station; 

• Sorting by agent group; 

• Showing active channels first. 
 

 
Channel list display settings are saved automatically and loaded on the next run. 

To sort channels by recording station, select View > Sort channels > By recording station menu option. 
Figure 11 shows an example of a channel list sorted by recording station. 

 
Figure 11: Channel list sorted by recording station 

To sort channels by agent groups, select View > Sort Channels > By agent group menu option. 
Figure 12 shows an example of a channel list sorted by agent group. 
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Figure 12: Channel list sorted by agent group 

The nested menu options in View > Sort channels have their checkboxes ticked in case the relevant 
sorting option is applied. To undo the sorting, just uncheck the checkbox by selecting the option once 
again. You can also select both options at a time; an example of such a configuration is detailed on 
Figure 13. 

 
Figure 13: Channel list sorted by both recording station and agent group 

To move active channels to the top of the list, select View > Show active channels first menu option. If 
you do so, the channels will be arranged in the following order: 

1. Active channels on which recording currently in progress. 

2. Channels for which recording is available but not currently in progress. 

3. Channels for which recording is disabled. 

4. Channels for which recording is unavailable. 
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When sorting, only sound recording state is relevant (video recording state is 
ignored). 

When this sorting mode is on, the channel positions are updated each time any channel changes its state. 

The View > Show active channels first option has its checkbox ticked if the mode is active. To deactivate 
it, untick the checkbox by selecting the option once again. 

 

4.1.5 Configuring Channel Recording Settings 
To enable audio channel recording, select Enable audio recording from the channel shortcut menu. 

To enable video channel recording, select Enable video recording option from the channel shortcut 
menu. 

You can also specify a recording mode for a channel. To do so, select Recording mode option from the 
channel shortcut menu to open a nested menu with a mode list: 

Recording 

 This mode is enabled by default. Recorded data are auto saved every 40 seconds and the 
application is processing the sound while it is being recorded. 

Resource saving recording 

 This mode enables saving and displaying the recording in the list only after the recording 
process is complete. In case you stop recording, the audio data will not be saved. 

Stop recording on request from Smart Logger 

 While this mode is on, if you disable active channel recording, the data being recorded is 
not saved nor does it appear in recording list. 

Recording on request from Smart Logger 

 By default, recording process is not run while on this mode. The process only starts when 
you click Enable sound recording in the shortcut menu. After the call is finished, the 
recording process becomes disabled again. 

Recording on request from phone, Stop recording on request from phone 

 These modes enable managing the recording process by means of HTTP requests. To run 
and stop recording via HTTP requests, you need to have On-Demand Recording Service 
module installed; otherwise, these modes will not differ from Recording on request from 
Smart Logger and Stop recording on request from Smart Logger. 
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For more in-depth information on Recording on request from Smart Logger and 
Stop recording on request from Smart modes, please refer to On-
Demand Recording Service Module. Administrator Guide. 

Active mode is displayed in the channel list status bar, and its checkbox is ticked in the nested menu 
(Fig. 14). 

 
Figure 14: Displaying active recording mode in the channel shortcut menu 

To view and edit audio and video channel recording parameters, select the Recording settings option 
from the channel shortcut menu.  

 

 
Before modifying parameters, disable channel recording (select Disable audio 
recording option from the shortcut menu). 

 

 
For more in-depth information on recording settings, please refer to the 
documents on the Recording module installed within the system. 

 

4.1.6 Multichannel Recording 
Multichannel recording implies recording multiple channels into a single audio file. You need to merge 
two or more channels (up to 8) to enable multichannel recording. 

 

 
For consistent merged channel recording, you need to select Original source 
codec in Recording settings (channel shortcut menu) for each channel.  
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Multichannel recording is available for analog lines only. You may merge only 
those channels which physically reside on the same board and support voice 
activation mode. Multichannel recording is hardware-based and supports only the 
following boards: STC-H205, STC-H205/4, STC-H219, STC-H219D, and STC-H433. 

To merge channels, you need to perform the following: 

1. Select multiple channels from the list, right-click to open the shortcut menu for one of the selected 
channels and click Disable audio recording. 

2. Open channel shortcut menu again and select Merge channels (Fig. 15). 

 
Figure 15: Merge channels options 

When you are done, the selected channels will be merged into a single group and labelled with 
multichannel recording icons (Fig. 16). 

 
Figure 16: Merged channel labelling 

The channel you selected first is a master channel labelled with  icon (see channel 15 on Figure 16). All 
other channels are known as slave channels and they are labelled with  icon (see channel 16 on Figure 
16). 

 

 
To enable or disable channel group recording, you have to access master channel 
shortcut menu. However, you may still configure parameters for each channel 
independently. 

To disable multichannel recording, select Split channels option in any merged channel shortcut menu 
(Fig. 17). 
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Figure 17: Splitting channels 

Merged channels are recorded into a single audio file, while the DB detects it as recorded through master 
channel (you can view master channel ID in  column of the recording list). While playing back such a 
recording (or live monitoring it), player waveform will reflect the actual number of channels. 

 

 
Master channel track will be listed in the player first. Other tracks will be located 
below, according to channel physical positions. 

 

 
While multichannel recording is running, recording color labelling in the player is 
unavailable. 

  

4.1.7 Managing Channels during Recording Process 
Once the recording process is run, the relevant channel row is highlighted green. In addition, Signal 
Level and Recording Mode columns change their values (Fig. 18). 

 
Figure 18: Channel view during recording process 

While the channel recording process is run, you may perform the following: 

1. Disabling sound data recording. To disable channel sound recording, select Disable audio 
recording option in its shortcut menu. 

In case you stop sound recording while the Recording mode is enabled, only a part of recording will be 
saved (as it is auto saved each 40 seconds). In other modes (Resource saving, Stop on request, 
Recording on request) the recording will not be saved if the process is stopped before the call has 
ended.  
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When you try to disable active channel recording, regardless of the mode enabled, the application will 
warn you about possible data loss. 

 

 
To avoid data loss, use Pause recording option from the channel shortcut menu 
(Fig. 19) to put the recording on hold: this way, you will enable the application to 
save the recorded part of a call. This option is available for analog channels only. 

 
Figure 19: Pause recording option enabling the app to save the data 

Once the channel recording is put on hold, the channel switches to the Pause mode. To exit this mode, 
select Resume recording option from the context menu (Fig. 20). 

 
Figure 20: Resume recording option 

2. Disabling video data recording. To disable channel video recording, select Disable video 
recording option in its shortcut menu. 

3. Color labelling the recording in progress to show its status. To place color labels, select Mark as 
option from the shortcut menu, then select a relevant status from the nested menu according to the 
color code (Fig. 21). Once the recording is complete, the relevant recording will be highlighted with 
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the color you selected. To learn more about color label configuration and default color labels, please 
refer to 5.4 Color Labels section. 

 
Figure 21: Color labelling 

4. Live monitoring (see below). 

 

4.1.8 Live Monitoring 
Using live monitoring feature, you can access a phone call in real time. 

To start live monitoring, double-click the required channel in the list or select Enable live conversation 
monitoring option from the channel shortcut menu. The player will show live monitoring is in progress 
(Fig. 22). 

 

 
Live monitoring is available both when recording is in progress and when it is 
stopped or disabled. For example, if a channel represents a microphone, live 
monitoring may be enabled while the channel is not recorded. 
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Figure 22: Live monitoring 

Use the player to manage audio and video playback. You will only have ACG, noise suppression and 
player options available (see 4.6 Audio and Video Playback section). 

To disable live channel monitoring, select Disable live conversation monitoring option in its shortcut 
menu. 
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4.2 Agent Performance Monitoring 
4.2.1 Feature Overview 
If the system contains information on call center agents, you can monitor call service using the agent list. 

Below there is a list of features enabling call service and agent performance monitoring. For more in-
depth information on each feature, please refer to the sections specified in the Guide Sections column. 

 

Feature GUI Elements 
Guide 
Sections 

Viewing agent list Recording area, Operators tab 4.2.2 

Updating agent list File > Refresh channel list menu 
option/F3 key/  toolbar button 

4.2.2 

Searching and filtering agent 
list 

 button, filter field above the agent 
list 

4.2.3 

Specifying standard call 
duration threshold 

Settings > Options > General tab, Call 
duration threshold option 

5.3 

Live agent conversation 
monitoring 

Double click a row in the agent 
list/Enable real-time line monitoring 
option in the shortcut menu 

4.2.4 

Live monitoring playback 
management 

Player GUI controls 4.6.3 

Recording color-code 
labelling 

Mark as option from the agent list 
shortcut menu 

4.2.5 

Adding and deleting list 
columns 

Customize grid option in column title 
shortcut menu of the agent list 

4.2.6 
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4.2.2 Viewing Agent List 
To view the agent list, go to the Operators tab located in the Recording area. 

Agent list stores info on all agents registered within the system. Figure 23 shows you how this list looks 
like. 

 
Figure 23: Operator (agent) list 

The rows showing the agents whose conversations are being currently recorded are highlighted green 
and marked with the  icon in the  column. 

 

The table below details all agent list columns. 
 

Title Description Details 

 Agent conversation 
recording status 

: The call being serviced is currently being 
recorded. 

: Recording is enabled but not currently in 
progress. 

: Recording is disabled. 
: Recording is unavailable (the agent has not 

logged in to the queue). 

 Agent screen video capture 
status 

: The call being serviced is currently being 
recorded. 

: Recording is enabled but not currently in 
progress. 

: Recording is disabled. 
: Recording is unavailable (the agent has not 

logged in to the queue). 
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Title Description Details 

 Live conversation 
monitoring status 

In case live conversation monitoring for the 
current channel is in progress,  icon will be 
displayed. Otherwise, the field will be blank. 

 Agent name Agent name 

 Agent phone number Agent phone number 

 Signal level  Active channel signal level. In case no 
channel activity is detected or the signal is too 
low, the field is blank. 

Start Call recording start time <HH>:<MM>:<SS> format. In case recording is 
not in progress, the field is blank. 

 Current recording duration <HH>:<MM>:<SS> format. In case recording is 
not in progress, the field is blank. If the duration 
exceeds the standard threshold value specified in 
system settings (which by default equals 2 
minutes), the time value is highlighted red:

 

 Call direction : outgoing call 

: incoming call 

VIP VIP customer indicator In case a VIP customer conversation is being 
recorded, the field will show the  icon. Aim your 
mouse pointer at the icon to view customer 
details: 

 
If the phone number is not included into VIP 
customer contact list, the field will remain blank 
(for more in-depth information on VIP customer 
contact list, please refer to Section 4.7). 

 External caller (customer) 
phone number 

Phone number 

 Channel ID Phone line ID, channel IP or MAC address 
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Title Description Details 

 Agent group name the 
agent belongs to 

Agent group name 

The upper part of the list shows current agent statistics by recording status (Fig. 24). 

 
Figure 24: Recording status statistics 

Statuses are shown in the same way as in  column: 

   Recording: The call being serviced is currently being recorded. 

   Ready: Recording is enabled but not currently in progress. 

   Off: Recording is disabled. 

   Logged out: Recording is unavailable (the agent has not logged in to the queue). 

For example, Figure 24 states that 5 calls are currently serviced and recorded and 10 more calls may be 
logged. When there is a call coming through one of those 10 channels, the recording process will start 
and the stats will be recalculated (Recording: 6, Ready: 9). Other statuses are updated in a similar way. 

Number of agents is updated automatically and is calculated on overall basis, regardless of any filter 
applied (see also Section 4.2.3). 

Sometimes you may want to refresh the agent list manually (e.g., new agents have recently been 
registered in the system). To refresh the list, select File > Refresh channel list menu option (alternatively, 
you can just press F3 or click the  toolbar button). 
 
 

4.2.3 Filtering Agent List 

To filter the agents by recording status, click the  button located on Operators tab and uncheck the 
statuses you do not need (Fig. 25). 

 
Figure 25: Filtering by recording status 
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The list will be updated and the status bar will show the filters applied (Fig. 26). 

 
Figure 26: List status bar 

The first status bar field shows the following: 

• Number of agents selected from the list. 

• Number of agents displayed after applying the filter(s). 

• Total number of agents registered in the system. 

The second status bar field displays recording status filters applied. 

To filter list objects by other parameters (agent name or phone number, customer phone number, 
channel ID, VIP customer details, agent group), start typing in the field located above the agent list 
(Fig. 27). 

 
Figure 27: Custom filter 

The list will display the agents that meet your search condition(s). The right-hand part of the field will 
show the number of matching search results. To clear the filter and go back to the common list, click . 

Any filters applied do not count for the recording status statistics displayed in the upper part of the tab. 

 
 

4.2.4 Live Monitoring 
As a Smart Logger II user, you can monitor the calls serviced by agents in real time; this is called Live 
Conversation Monitoring). 
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Live monitoring may be enabled only for those agent calls that are being currently 
recorded (in this case the rows for the agents in question will be highlighted green 
and have the  icon in the  column). 

To enable live monitoring, double click the relevant row in the agent list or select Enable live monitoring 
option from the shortcut menu. 

The player status bar will show the channel is currently being monitored (Fig. 28). 

 
Figure 28: Live monitoring 

Use the player to manage audio and video playback. You will only have ACG, noise suppression and 
player options available (see 4.6 Audio and Video Playback section). 

While live monitoring is on, you can listen to all the calls serviced by the agent in question. When a 
current call ends, the monitoring will be paused, and when another call comes in, it will be automatically 
resumed. 

In case screen monitoring option is enabled for this user account, it will run at the same time with audio 
playback. A video monitoring dialog will show up in the top left-hand corner of the screen.  

 

 
Video monitoring is available if this option is enabled for the current user account. 
The  column displays which users with have this feature enabled (  or ). 

 

 
Video monitoring option can be enabled in the player settings (see Section 
4.6.6 Player Options). 
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Use the video monitoring dialog shortcut menu to adjust its size. This configuration will be saved.  

To switch to another agent, double click the relevant row in the agent list or select Enable live 
monitoring option from the row shortcut menu. 

To disable live channel monitoring, select Disable live monitoring option in its shortcut menu. 

4.2.5 Color Labelling 
While an agent is handling a call, you can mark the audio being recorded with a color label to denote its 
status. 

 

 
Color labelling is only available for the agent conversations being processed at the 
moment (the relevant rows are highlighted green and marked with the  icon in 
the  column). 

To mark a recording with a color label, select the Mark as option from the relevant row shortcut menu. 
Then, select a status according to the color code (Fig. 29). The row in question will be highlighted with the 
relevant color. 

 
Figure 29: Marking an audio being recorded 

To learn more about color label configuration and default color labels, please refer to 5.4 Color Labels 
section. 

 

4.2.6 Configuring Visible Columns 
You can customize the following list display settings: 

• 1. Column order: drag and drop column titles. 
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• 2. Column width: change it using your mouse pointer. 

• 3. Sorting list elements by columns: click the title of the column in question. 

• 4. Configuring visible columns: select the Customize grid option from any column shortcut menu 
(Fig. 30). 

 
Figure 30: Shortcut menu for customizing visible columns 

After selecting Customize grid option a dialog will show up (see Fig 31). 

 
Figure 31: Grid customization dialog 

The dialog includes the following sections: 

Available fields 

 A list of columns which are not currently visible in the agent list. 

Visible fields 

 A list of columns which are currently visible in the agent list. 

To display hidden columns in the agent list, select them in the Available fields list and click . 

To hide visible columns in the agent list, select them in the Visible fields list and click . 

To change column order, use the  and  buttons in the right-hand part of the dialog. 
 

 
To learn which name the icon-like column title stands for, move your mouse 
pointer to the column title, and a hint will pop up. This hint text is used to denote 
a column in the Grid customization dialog. 
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To apply changes, click the Apply button in the grid customization dialog (see Fig. 31). To apply changes 
and close the dialog, click ОК. 

 

 
Agent list display settings are saved automatically and loaded on the next run. 

 

4.3 Working with Recording Lists 
4.3.1 Feature Overview 
You can add new tabs with recording lists in the Database area. Each list may be customized and is 
formed though recording filtering process. This allows you to distribute the data, collected according to 
specific criteria, over multiple tabs. 

Below there is a list of features regarding recording lists. For more in-depth information on each feature, 
please refer to the sections specified in the Guide Sections column. 

 

Feature GUI Elements 
Guide 
Sections 

Adding a new list  button on an empty tab 4.3.2 

Deleting a list  (close) button on a tab 4.3.2 

Renaming a list tab Tab shortcut menu, Rename option 4.3.2 

Setting refresh options Auto refresh button and Refresh rate 
field below the recording list 

4.3.3 

Refreshing recording lists Recording list > Refresh recording list 
menu option/F5 key/  toolbar button 

4.3.3 

Viewing recording lists Recording list tab in the Database area 4.3.4 

Viewing complex recordings  element to the left of a complex 
recording title in the recording list 

4.3.5 

Adding and removing list 
columns 

Customize grid option from the column 
title shortcut menu 

4.3.6 

For information on how to work with filters, please refer to 4.4 Searching for Recordings. 
  

4.3.2 Creating and Deleting Lists 
To add a tab, click the  button on a blank tab. By default, the new tab will be given a name consisting of 
the word List and an ordinal number. 

The new list will include all audio file labels recorded during the current day. 

To rename a list, right-click the tab name and select Rename (Fig. 32). 
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Figure 32: New tab button and its right-click menu 

 

Enter a new name using the dialog (Fig. 33) and click OK. 

 
Figure 33: Entering new tab name 

To delete a list (close a tab), use the  (close) button located on the tab in question. Once closed, the tab 
cannot be restored. 

 

 
Overall number of recording list tabs in the Database area may not exceed 10. 

 
 

4.3.3 Refresh Options 
Each recording list may be refreshed in one of the following modes: 

1. Manual refresh mode (active by default). While running the app with this mode enabled, you can 
filter recordings by date and time using the calendar and other control elements in the right-hand 
part of the screen (Fig. 34, see also Section 4.4.2). 

 
Figure 34: Recording list with manual refresh mode disabled 
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When this mode is enabled, you can refresh the list by selecting Recording list > Refresh recording list 
menu option, as well as by pressing F5 or clicking the  toolbar button. 

2. Auto refresh mode. To enable this mode, click the Auto refresh button located below the list. 
Figure 35 shows how a recording list may look like when the auto refresh mode is on. 

 

 
While in auto refresh mode, the recording list includes only the data recorded 
within an hour. 

 

 

 
Figure 35: Recording list with auto refresh mode enabled 

While this mode is on, the list is updated automatically once a fixed period you can specify in Refresh 
period field (by default, it equals 30 seconds). Filtering recordings by date and time, in this case, is 
unavailable, as the calendar is hidden. 

To disable auto refresh mode, click Auto refresh once again. 
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4.3.4 Viewing Recording List 
You can view the recording list on the List <N> tab within the Database area (<N> stands for the list 
ordinal number). 

A recording list is a table where the columns show each recording’s properties. You can see a fragment of 
such a table on Figure 36. 

 
Figure 36: Recording list fragment 

You can see the column titles by aiming your mouse pointer at the title icons. 

The info displayed in the list columns is filled in while saving the recording with the recording service or 
after further recording processing with additional software components. For more information on the 
components obligatory for filling in the recording list columns, please see the table below (Component 
column). For editable parameters, Smart Logger II application is specified as a component (see 
also 4.5.2 Viewing and Editing Recording ). 

 

 
If one more components are not installed, the recording list columns filled in with 
these components are blank. 

 

 

Title Description Value/Details Component 

 Recording start date 
and time 

Date and time Recording service 

 Recording duration Time Recording service 

 Subscriber 1 Call center agent 
(internal caller) 
number 

Phone number Recording service, 
Smart Logger II 
application 

 Call direction  Outgoing call 
 Incoming call 

Recording service, 
Smart Logger II 
application 



Smart Logger II 
Working with the Application User Guide 

 

 48 Smart Logger II 
 

 

Title Description Value/Details Component 

 Subscriber 2 External caller number Phone number Recording service, 
Smart Logger II 
application 

 Recording processed 
(played back)  

 Recording has been 
played back through the 
player; otherwise, the 
field is blank. 

Smart Logger II 
application 

 Important recording  The recording has been 
marked as important; 
otherwise, the field is 
blank. 

Smart Logger II 
application 

 The recording is 
marked to delete 

 Recording marked to 
delete. 
Otherwise, the field is 
blank. 

Smart Logger II 
application 

 Recording status  Recording is in 
progress or has been 
paused.  

 The call has been 
missed. 
Otherwise, the field is 
blank. 

Recording service 

 Audio file status Displays audio file 
transfer status when on-
request transfer is in use: 
Not found, Requested, 
Ready to playback. 

File Server 

 Unique recording ID ID Recording service 

 Recording station 
name where the audio 
file was recorded 

DNS server name Recording service 

 Recording channel ID ID Recording service 

Recording 
channel name 

Name of the channel 
the audio file was 
recorded through 

Text Recording service 

 Operator Name of the call center 
agent handling the 
conversation 

Text CTI Analyzer 



Smart Logger II 
Working with the Application User Guide 

 

 49 Smart Logger II 
 

 

Title Description Value/Details Component 

 Group Relevant agent group 
name 

Text Recording service, 
CTI Analyzer 

 Department Name of the 
department the agent 
group refers to. 

Text Recording service 

Full name 1 Agent (internal caller) 
full name 

Text Smart Logger II 
application 

Full name 2 Customer (external 
caller) full name 

Text Smart Logger II 
application, 
Recording service 

 Recording ID in a 
channel 

Ordinal number Recording service 

 Customer call count 
(current day) 

Call count Recording service 

 Customer call count 
(current week) 

Call count Recording service 

 Customer call count 
(current month) 

Call count Recording service 

 Agent speech 
percentage 

Percentage Recording service 

 Customer speech 
percentage 

Percentage Recording service 

 Agent speech duration 
to customer speech 
duration ratio 

Decimal ratio Recording service 

 Silence ratio Percentage Recording service 

 Talking over ratio Percentage Recording service 

 Agent speech duration Time in seconds Recording service 

 Customer speech 
duration  

Time in seconds Recording service 

 Silence duration Time in seconds Recording service 

 Maximum agent 
speech fragment 
duration 

Time in seconds Recording service 
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Title Description Value/Details Component 

 Maximum customer 
speech fragment 
duration 

Time in seconds Recording service 

 Maximum silence 
speech fragment 
duration 

Time in seconds Recording service 

 Number of times the 
agent interrupted the 
customer 

Number of interruptions Recording service 

 Number of times the 
customer interrupted 
the agent 

Number of interruptions Recording service 

 Repeat call detected  The customer has 
called at least twice 
within last 24 hours. 

 There have been no 
repeat calls from the 
customer within last 24 
hours. 

Recording service 

 Recording status 
(archived/not 
archived) 

 The recording has 
been archived. 
Otherwise, the field is 
blank. 

Archiver 

 Transcription 
availability 

 Transcription is 
available for this 
recording. 
Otherwise, the field is 
blank. 

Transcriber-Word 

 Video availability  Agent video screen 
capture is available. 
Otherwise, the field is 
blank. 

Screen Recording 

 Video recording status  Recording is in 
progress or has been 
paused. 
Otherwise, the field is 
blank. 

Screen Recording 

Label name Audio file status 
assigned via a color 
label 

Audio file status is 
displayed if there is a 
color label assigned to it. 

Smart Logger II 
application 
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Title Description Value/Details Component 

 Fax message detector  The recording is 
actually a fax message. 
Otherwise, the field is 
blank. 

Fax Reader 

 Fax message decoding 
status 

 The message has been 
decoded and is available 
to view as an image. 

 A decoding error has 
occurred. 
Otherwise, the field is 
blank. 

Fax Reader 

 Speech recognition 
status 

 Speech recognition is 
in progress. 

 Recognition has been 
completed, transcription 
is available. 

 A recognition error has 
occurred. 

FTR Service 

VIP VIP customer 
conversation detected 

 VIP customer 
conversation. 
Otherwise, the field is 
blank. 

Recording service 

 Good speech quality 
detected 

 Agent speech quality 
is applicable for 
recognition and analysis. 
Otherwise, the field is 
blank. 

Recording service 

 QM task status  QM task has been 
completed. 

 The task is active but 
not yet completed. 
Blank field: no QM task. 

QM Analyzer 

 Figure-based 
assessment result 

 Excellent 
 Good 
 Okay 
  Bad 
 Unspecified 

QM Analyzer 

 Lexical and semantic 
assessment result 

Same as above. QM Analyzer 
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Title Description Value/Details Component 

 Emotion-based 
assessment result 

Same as above. QM Analyzer 

 Aggregate rating Same as above. QM Analyzer 

Keywords Keywords Words separated with 
comma 

QM Analyzer, 
Smart Logger II 
application 

CTI call ID CTI call ID Call ID CTI Analyzer 

Call transfer 
number 

Phone number the call 
was transferred to. 

Phone number CTI Analyzer 

 Time to answer the call Time in seconds CTI Analyzer 

 Overall hold time Time in seconds CTI Analyzer 

 Maximum hold time  Time in seconds CTI Analyzer 

 Number of calls that 
were put on hold. 

Number of holds CTI Analyzer 

 Overall mute time Time in seconds CTI Analyzer 

 Maximum mute time  Time in seconds CTI Analyzer 

 Number of mutes Number of mutes CTI Analyzer 

 Number of transfers Number of transfers CTI Analyzer 

 Call ended while on 
hold 

 The call ended while it 
was on hold. 
Otherwise, the field is 
blank. 

CTI Analyzer 

 Call ended by  Call ended by an 
agent. 

 Call ended by a 
customer. 
Blank field: cannot be 
specified. 

CTI Analyzer 

 Time to wait in the 
queue 

Time in seconds CTI Analyzer 

Complex call 
ended 

Shows if a complex call 
(the one including 
holds and transfers) 
has ended. 

0 Call ended 
1 Call still in progress 

CTI Analyzer 
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Title Description Value/Details Component 

Internal call Shows if a call is 
internal in which only 
call center agents are 
involved. 

1 Internal call 
0 External call (customer 
is involved) 

CTI Analyzer 

Customizable 
field 

Five fields for which 
names and purposes 
are specified when 
setting up the system. 

Values are specified 
within the modules for 
which the fields were 
created. 

Modules for which 
the fields were 
created 

Comment Comment to the 
recording 

Comment text Smart Logger II 
application 

The recordings within the list may be highlighted with a color that defines their status (to learn more 
about color label configuration and default color labels, please refer to 5.4 Color Labels). 

 

 
If an audio file is not found or has not been transferred yet from the recording 
station to the centralized storage, the relevant row will be highlighted grey. File 

transfer status is displayed in the column. In case the file has not been 
transferred to the storage, it will be played back from the recording station 
directly. Such recordings are also available to export. 

Below the recording list there are several fields displaying the following info: 

• Overall number of recordings in the list. 

• Number of selected recordings. 

• Overall number of recordings in the DB. 

• Refresh mode details (Fig. 37). 

 
Figure 37: Recording list information fields 

 

4.3.5 Complex Recordings 
The recording list displays both simple (consisting of a single audio file) and complex recordings 
(consisting of multiple files). 

Complex recordings are created in the DB in the following cases: 

• When a call is put on hold. 

• When a call is transferred. 
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The list element that refers to a complex recording hosts a nested list of simple recordings. To expand it, 
click the   icon to the left of the complex recording title (Fig. 38). 

 
Figure 38: Complex recordings 

A complex recording will display the properties (date/time, callers, etc.) of the first simple recording that 
forms a part of it. 

 

 
Simple audio files being a part of a complex recording will not be merged 
together as long as at least one of them is still in the process of recording (ongoing 
recordings are marked with the  icon). Complex recordings are updated each 
minute. To update the list of recordings manually, select Recording list > Refresh 
recording list option/F5 key/  toolbar button. 

 

 
Complex recordings will be displayed in the list only in case the recording module 
supports complex call recording and the CTI Analyzer module is installed within 
the Smart Logger II system. 

In case the recording module does not support logging complex calls, the calls put on hold will be 
recorded into a single file; as for the transfers, they will be shown by marking the external caller number 
with a hash key (#). 

Figure 39 shows an example of incoming call where the external caller (456) makes a call to the agent 
(123) that is then transferred to 789. 

 
Figure 39: An example of displaying a transfer in the recording list 

To learn more about call processing and saving recording info while logging calls coming through digital 
lines, please refer to Appendix A. Call Processing Scenarios. 
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4.3.6 Configuring Visible Columns 
• You can customize the following list display settings: 

• 1. Configuring visible columns: select the Customize grid option from any column shortcut menu 
(Fig. 40). 

 
Figure 40: Shortcut menu for customizing visible columns 

• 2. Column order: drag and drop column titles. 

• 3. Column width: change it using your mouse pointer. 

• 4. Sorting list elements by columns: click the title of the column in question. To sort the list by 
multiple columns you may want to use custom filters (see 4.4.3 Custom Filters). 

After you select the Customize grid option, the following dialog (Fig. 41) will show up: 

 
Figure 41: Recording list grid customization dialog 

The dialog includes the following sections: 

Available fields 

 A list of columns that are not currently visible in the recording list. 

Visible fields 

 A list of columns that are currently visible in the recording list. 

Save as default 

Tick this checkbox to display all selected columns on all recording list tabs. 
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To display hidden columns in the recording list, select them in the Available fields list and click . 

To hide visible columns in the recording list, select them in the Visible fields list and click . 

To change column order, use the  and  buttons in the right-hand part of the dialog. 
 

 
To learn which name the icon-like column title stands for, move your mouse 
pointer to the column title, and a hint will pop up. This hint text is used to denote 
a column in the Grid customization dialog. 

To apply changes, click the Apply button in the grid customization dialog (see Fig. 41). To apply changes 
and close the dialog, click ОК. 

 

 
Recording list display settings are saved automatically and loaded on the next run. 
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4.4 Searching for Recordings 
4.4.1 Feature Overview 
Below there is a list of features available for recording search. For more in-depth information on each 
feature, please refer to the sections specified in the Guide Sections column. 

 

Feature GUI Elements 
Guide 
Sections 

Searching recordings by date 
and time 

Calendar and additional GUI controls in 
the right part of the recording list 

4.4.2 

Custom filter configuration Recording list > Filter menu option/F6 
key/  toolbar button/Filter 
configuration option from the tab 
shortcut menu 

4.4.3 

Selecting a custom filter to 
search recordings in the list 

Recording list > Filter option/F6 key/ 
 toolbar button/Filters menu on the 

start page 

4.4.3 

Quick filters Recording shortcut menu (clicking the 
field where filtering is required) 

4.4.4 

Recording search by ID Ctrl+F shortcut (in the recording list) 4.4.5 

Quick search Typing the relevant text in the list 3.4 

Quick search is available for the following recording list columns: 

•  (ID) 

•  Date and time (recording start date and time) 

•  Subscriber 1 (internal caller number) 

•  Subscriber 2 (external caller number) 
 

 
The number of recordings that may be displayed in the list is limited. If the number 
of found recordings exceeds the limit, the rest of the recordings will not be 
displayed. A relevant warning will show up (Fig. 42). 
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Figure 42: Warning on exceeding the maximum number of recordings 

Figure 42 depicts a case when the maximum number of displayed recording is 5000 and the number of 
found recordings exceeds it. To resolve this issue, change the maximum number value (Tools > Options 
menu, General tab, Maximum number of recordings in a recording list option, see Section 5.3) or 
specify different search conditions. 
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4.4.2 Searching by Date and Time 
To search the recordings by date and time, use the calendar and additional GUI controls in the right part 
of the screen (Fig. 43). 

 
Figure 43: Date and time selection panel 

To switch from one month to another, use the  and  buttons in the upper part of the calendar. 

Current date is highlighted orange in the calendar. The selected dates are highlighted blue. 

The list will display only those elements that refer to the period, selected using GUI controls detailed on 
Figure 43. 

To select a day in the calendar, just click that day; then you may specify the required period using the 
timescale. Figure 44 shows the GUI controls with a specific day selected. 
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Selected date 
 
Current date 

 

1 Calendar 

2 Timescale 

3 Predefined periods 

Figure 44: Selecting a single day in the calendar 

The timescale (see Fig. 44) allows you to specify time within a single day selected in the calendar. You 
may either type the values in or select an area on the graphical representation of the scale using your 
mouse. The minimum time period you can specify is 10 minutes. 

To select multiple consecutive days, click the first day and drag your mouse pointer to the last day, then 
release the button. You can also use the Shift key to perform this action. 

 

 
The maximum time period you can specify equals 500 days. 

To select a week, aim your mouse pointer to the left of a calendar row that corresponds to the relevant 
week, and click this area to select the whole row. 

1 

2 

3 
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If multiple days or a week are selected, the controls will look like Figure 45 shows. 

Selected period 
 
Current date 

 

1 Calendar 

2 Period selection boxes 

3 Predefined period 

Figure 45: Selecting multiple days in the calendar 

Using period selection boxes (see Fig. 45), you can manually adjust start and end dates. 

To select a predefined period (see Fig. 44, 45), click one of the following links: 

• Last hour: One hour prior to the present moment 

• Today: Current date 

• Current week: Current calendar week 

• Current month: Current calendar month 
 

4.4.3 Custom Filters 
A custom filter is a named set of parameters intended to sort and search entries in a recording list. 

 

 
The GUI elements designed to work with filters are available when a recording list 
is active. 

To configure custom filters, select Recording list > Filter menu option. Alternatively, you can press F6, 
click the  toolbar button or select Filter configuration option from the tab shortcut menu. You will 
see then the Filtering and sorting dialog shown on Fig. 46. 

1 

2 

3 
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Figure 46: Filtering and sorting dialog 

The dialog consists of multiple tabs, each used to configure specific filtering options. 

The first tab displays a summary of all configured parameters. If a filtering option is configured, the 
relevant tab title, highlighted bold, will display the number of parameters involved. 

On filter configuration tabs, tick checkboxes for the parameters you want to use for filtering. To specify 
filtering conditions, use input boxes and other GUI controls. 

Figure 46 shows a filter configured to display 20 randomly selected recordings made through the 
specified channel and marked as processed. 

You can use masks to filter phone numbers (Fig. 47). Multiple numbers must be separated with comma. 
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Figure 47: Using masks to filter phone numbers 

? (question mark) is a placeholder for any number, e.g. +44?00 may stand for +44000, +44100, +44200, 
etc. 

* (asterisk) is a placeholder for any sequence of numbers, e.g. 91* stands for all numbers starting with 91. 
 

 
To search text containing commas, use a question mark (?) instead of a comma (,). 
E.g., to search for John Doe, Customer Support Agent, enter John Doe? 
Customer Support Agent. 

On the Sorting tab select recording list columns to sort filtering results (Fig. 48). 
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Figure 48: Sorting/filtering result configuration 

The fields available for sorting are displayed in the left-hand list. The list on the right displays the fields 
the sorting will be applied to. To move the fields between the lists use the  and  buttons. To change 
the order of the fields used for sorting, click  or . To toggle sorting direction, select a row in the right-
hand list and click Sorting direction. 

To save or delete filters, use Custom filters area. 

The field displaying Custom filter by default (Fig. 46) is intended for entering filter name. Type a new 
name here to create a new filter. 

To make the filter accessible for all users, check the Shared button. 

To save the new filter, click Save. 
 

 
You do not have to save a filter if you are going to apply it only once. 

To edit an existing filter, select it from the dropdown list, edit all required parameters and click Save. To 
delete the selected filter, click Delete. 

To clear all filtering parameters, click Clear all. 

To display the filtering results on a new tab, tick the Open in a new tab checkbox; otherwise, the results 
will be displayed in the active tab. To apply the filter in question to the selected recording list, click ОК. 

To apply a previously saved custom filter, you can perform one of the following actions: 
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1. Select a filter through filter configuration dialog (see Fig. 46). 

2. Select a filter from the list you can access by clicking the  toolbar button (Fig. 49). This list 
displays all available custom filters. 

 
Figure 49: An example of a filter selection list located on the toolbar 

3. Select a filter from the Filters group located on the start page (Fig. 50). The list displays recently 
applied custom filters (the list cannot display more than 5 items). 

 
Figure 50: Filters displayed on the start page 

You may apply only one custom filter to each recording list. If a filter has already been applied, the toolbar 
button will change to . The button dropdown list houses menu options for selecting filters. The 
recording list tab title shows the  icon and the filter name. On Figure 51 you can see how the GUI 
controls look like when To process filter is selected. 
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Figure 51: GUI elements when a filter is applied 

To view currently applied filter settings, move your mouse pointer to the tab (see Fig. 51). 

To clear a filter applied to an active recording list, perform one of the following: 

4. Open filter configuration dialog (Recording list > Filter configuration) and click Clear all 
(Fig. 46). 

5. Select Disable filter from the filter dropdown list located on the toolbar (Fig. 51). 

6. Select Clear filter option from any recording shortcut menu. 

 

4.4.4 Quick Filters 
Quick filters allow recording list data filtering without configuring it through Filtering and sorting 
dialog. 

You can apply quick filters to the following recording list fields: 

   Subscriber 1(internal caller number) 

   Subscriber 2 (external caller number) 

   (agent name) 

   (agent group name) 

   (call direction) 

   (recording duration) 

   (important recording) 

Keywords 

Channel name 

To apply a quick filter to any of lists mentioned above, right-click the field and select a filter condition 
from the shortcut menu. You can see an example of the Duration field filtering shortcut menu on 
Figure 52. 
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Figure 52: Recording duration quick filters 

 

 
Recording duration quick filtering is applied to overall complex recording 
duration, if there is any. E.g., in case the list has two simple recordings, 10 seconds 
each, forming part of a complex recording, the All recordings less than 15 
seconds query will return no results. 

The recordings that match the filtering condition you have specified are shown on the same tab. 

You will see the  icon next to the active tab title; this icon tells you that a filter is applied to the list 
(Fig. 53). 

 
Figure 53: Tabs showing there is a filter applied to the list 

You can apply multiple quick filters to multiple recording list fields, one by one. 

You can also use quick filtering to sort labelled recordings. In this case, the quick filtering option is always 
available in the shortcut menu, whichever field you click (Fig. 54). 

 
Figure 54: Quick filtering for recordings labelled with color 
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To remove the recordings that meet a certain filtering condition from the search result, right-click the 
relevant field and select Remove <filtering option> filter. 

To clear all quick filters on an active tab, right-click any field for which quick filtering is available and select 
Clear filter (Fig. 55). 

 
Figure 55: Clearing filter options 

After clearing all filters the  icon will be no longer displayed next to the tab title. 

 

4.4.5 Searching by ID 
To search a recording by its ID, press Ctrl+F while a recording list is active. Specify the recording ID’s 
separating them with commas in the dialog that shows up (Fig. 56). 

 
Figure 56: Find recordings by ID dialog 

 

 
The search detects 100% matches only. 

The search results will be displayed in the recording list. To restore the original list, refresh it (Recording 
list > Refresh recording list option/F5 key/  toolbar button). 
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4.5 Working with Recordings 
4.5.1 Feature Overview 
To work with recordings, use recording shortcut menu in the recording list. To open the shortcut menu, 
right-click a recording shown in the list. If you select a single recording, the menu will look like shown on 
Figure 57. This menu has options to work with a single recording. 

 
Figure 57: Recording shortcut menu 

If you select multiple recordings, the menu will look like shown on Figure 58. This menu lists options for 
working with multiples recording. 

 
Figure 58: Recording shortcut menu when multiple recordings are selected 

 

 
To select multiple list elements, use the same keys as for other Windows-based 
applications (Ctrl and Shift). 

Below there is a list of actions you can perform using recording shortcut menu. For more in-depth 
information on each feature, please refer to the sections specified in the Guide Sections column. 
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Feature 
Shortcut Menu Options/Other Ways to 
Perform the Same Actions 

Guide 
Sections 

Viewing and editing recording 
details 

Recording label 4.5.2 

Playing back a recording Play/Double-click a recording in the list 4.5.3, 4.6 

Playing back multiple 
recordings one by one 

Play one by one/Double click one of the 
selected recordings 

4.5.3, 4.6 

Playing back multiple 
recordings simultaneously 

Play simultaneously 4.5.3, 4.6.2 

Deleting a recording and its 
details 

Delete, Delete selected/Delete key 4.5.5 

Viewing call statistics Show call stats – 

Print recording info Print – 

Export recordings, videos or 
recording info 

Export 4.5.6 

Recording color labelling Mark as/Ctrl+<N> shortcut, where 
<N> stands for recording status number 

4.5.8 

Recording transcription Open with Transcriber 4.5.9 

Recording shortcut menu may also list other options in case additional features are available. Some 
options may be missing if unavailable for the selected recordings. 

 

4.5.2 Viewing and Editing Recording Label 
Recording labels include information on a recording stored in DB. 

To view or edit recording details, select the Recording details option for the recording shortcut menu. A 
dialog shown on Figure 59 will appear. 
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Figure 59: Recording details 

The Recording information area (Fig. 60) consists of read-only info fields (except for Fax message and 
Fax decoded checkboxes that are editable). You can find each field description below. 

 
Figure 60: Recording information area 

Recording ID 

 A unique ID assigned to a recording. This field corresponds to the recording list column 
titled with the  icon. 

Channel ID 

 A unique ID assigned to the channel which the recording was made through. This field 
corresponds to the recording list column titled with the  icon. 

Recording station 

 The recording station where the recording was made. This field corresponds to the 
recording list column titled with the  icon. 

Date and time 

 Recording start date and time. This field corresponds to the recording list column titled 
with the  icon. 
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Duration 

 Recording duration. This field corresponds to the recording list column titled with the  
icon. 

Recording complete 

 Recording status. If the recording process has been completed, the checkbox is ticked. The 
checkbox refers to the recording list column titled with the  icon (in case the process is 
complete, the icon is not displayed). 

Stored on CD 

 The checkbox is ticked if the recording has been saved to a CD. The checkbox refers to the 
recording list column titled with the  icon. 

Fax recording 

 This checkbox is ticked in case the recording is actually a fax message. The checkbox refers 
to the recording list column titled with the  icon. You can check it manually if you want 
to mark the recording as a fax message. 

Fax decoded 

 This checkbox is ticked if the fax message has been decoded. The checkbox refers to the 
recording list column titled with the  icon. You can check it manually to mark the fax 
message as decoded (note that it will be grayed out if Includes a fax message checkbox is 
unticked). 

Transcribed 

 This checkbox is ticked if there is a transcription for this recording. The checkbox refers to 
the recording list column titled with the  icon. 

Call information area (Fig. 61) hosts a table with editable fields. Here you can add and/or edit caller 
details (Subscriber 1 is for internal caller, Subscriber 2 is external caller), i.e. callers’ Phone number and 
Full name. 

 
Figure 61: Call information area 
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Below the table, you will find the following fields and checkboxes: 

Agent 

 Agent that handles the call. 

Group 

 Group the agent belongs to. 

Direction 

 Call direction you can select from the dropdown list. The options are the following: 

Inbound: an inbound call (  icon in the  recording list column) 
Outbound: an outbound call (  icon in the  recording list column) 
None: call direction is not specified (the  recording list column is blank). 

Important 

 If the recording is marked as important, the checkbox is ticked. The checkbox refers to the 
recording list column titled with the  icon. 

Processed 

 The checkbox is ticked if the recording has been processed (played back through the 
player). This checkbox refers to the recording list column titled with the  icon. 

To delete 

 The checkbox is ticked if the recording has been marked to delete. This checkbox refers to 
the recording list column titled with the  icon. 
 

Missed call 

 The checkbox is ticked if the call has been missed. Missed calls are shown as  in the  
recording list column. 

Additional information area (Fig. 62) has some editable fields described below. 

 
Figure 62: Additional information area 
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Comment 

 A comment referring to the recording (e.g. call summary). This field corresponds to the 
Comment recording list column. 

Keywords 

 Keywords used to optimize recording search. These words may be found automatically by 
means of QM Analyzer tasks. The field refers to the Keywords recording list column. 

There are also some buttons on the lower part of the Recording details dialog. They are shown on 
Figure 63 and described below. 

 
Figure 63: Recording details dialog buttons 

<< Go to the previous recording labels without saving changes. 

>> Go to the next recording details without saving changes. 

Play 

 Play the recording through the player. 

Restore 

 Restore the details that were modified while editing. 

Save 

 Save the edited info. 

Close 

 Close the recording details dialog. 

Once you close the dialog, you will see the applied changes appear in the recording list. 

 

4.5.3 Playing back the Recordings 
To play a recording using the player, select Play from recording shortcut menu or double-click it in the 
list. The recording will be loaded to the player (Fig. 64). 

 
Figure 64: Playing back the recording 
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In case Download files before playback option (Tools > Options menu, General 
tab) is enabled, Smart Logger will copy the file from the network location to your 
PC prior to playing it back. While copying, you will see a status bar with an option 
to cancel the download. When playing back the same recording again, the app will 
access the downloaded file, i.e. you will not have to download it once more. 

To play back multiple recordings one by one, select them in the list and either click Play one by one 
option in the recording shortcut menu or double-click any selected recording. The recordings will be 
loaded to the player one by one, keeping their original order in the list. 

 

 
When playing back a complex recording, the simple recordings it includes will be 
played one by one. 

To play back multiple recordings simultaneously (maintaining their chronological order), select them in 
the list and click Play simultaneously option in the recording shortcut menu. 

If there is also a video screen capture, it will be played at the same time as the recording. Video recordings 
are marked with the  icon in the list. Video playback screen shows up in the top right-hand corner by 
default. 

 

 
You can enable the video playback option in the player settings (see Section 
4.6.6 Player Options). 

Use the video playback screen shortcut menu to adjust its size and location. This configuration will be 
saved.  

 

 
While playing back complex recordings or multiple recordings simultaneously, 
you cannot play any video. 

Each simple recording being a part of a complex one contains a separate video file. To play back video 
files for each simple recording, expand a complex recording and select a simple recording you want to 
play back.  (Fig. 65). 
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Figure 65: Playing back a part of a complex recording 

For more in-depth information on working with the player, please see 4.6 Audio and Video Playback. 

 

4.5.4 Recording Integrity Check 
While the recording is being played back (or loaded into the player), Smart Logger II performs audio file 
authentication and integrity check through the following steps: 

• Verifying file digital signature. 

• Checking if the file name matches the one stored in metadata. 

• Verifying the watermarks embedded into the file. 
 

 
When loading multiple recordings into the player, no check is performed. 

The player displays authentication/check status icon in its right bottom corner (Fig. 66). 

 
Figure 66: Check status icon 

After both authentication and integrity check are over, the overall result is displayed (Fig. 67, 68) 

 
Figure 67: Authentication success 
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Figure 68: Authentication failure 

To view the result of all three authentication/check steps, click the icon (Fig. 69). 

 
Figure 69: Authentication steps results 

   Authentication is a success (the file is authentic). 

   Authentication failed: file authenticity issues or integrity damage detected (either the file is 
not authentic or the application was unable to read the embedded info). 

   Authentication is not available (digital signature, metadata or watermarks are missing). 

The final authentication/integrity check result (an icon displayed in the player area) depends on the 
following criteria: 

1. The file is not deemed authentic if any of the authentication steps has failed. 

2. Otherwise: 

If digital signature authentication is successful, the file is deemed authentic. 

If digital signature authentication is not available, then the whole authentication process is deemed 
unavailable. 
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You can see some examples of authentication results in the table below. 
    

Digital Signature File Name Watermarks Final Result 

    

    

    

    

    

    

    
 

To view watermarks embedded into the recording, click the link (Fig. 70). You can view the watermarks if 
they cannot be read correctly from the file. 

     
Figure 70: Links to view watermarks 

An independent window with embedded watermark list will pop up. 
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If the watermarks are valid, the window will show a single file fragment, its duration equaling that of the 
recording (Fig. 71). 

 
Figure 71: Valid watermarks 

If the file is corrupt (watermarks are invalid), the modified fragment will be highlighted red (Fig. 72). 

 
Figure 72: Corrupt file fragment 

 

 
Double-click the fragment to play it. The playback will start from the timestamp 
shown in the Start column. 
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4.5.5 Deleting Recordings 
Recording deletion implies deleting the audio file, the video file and the recording info from the DB. 

To delete a recording or mark it to delete, select the Delete option from its shortcut menu hit the Delete 
key. You will then see the dialog shown on Figure 73. 

 
Figure 73: Deleting recordings dialog 

Tick the Delete immediately checkbox to delete the file(s) and the info stored in the DB right away. 

To confirm deletion, click Yes. If you decided to delete the recording immediately, the deletion process 
will start straight away. 

 

 
In case you send a request to delete a recording (with Delete immediately 
checkbox ticked) while its playback is in progress, the playback will be stopped and 
the recording will be unloaded from the player. If the recording is being played 
back on another client application instance, you will be unable to delete it. 

In case you have left the Delete immediately checkbox unticked, the recording will be marked as  in 
the column highlighted on Figure 74. Such recordings are stored on the disk and in the DB until you 
delete them manually or through the cyclic recording mode. 

 
Figure 74: Displaying the recordings marked to delete 

To delete multiple recordings, select them in the list and click the Delete selected option in the shortcut 
menu or hit Delete. The process of deleting multiple recordings is similar to that of a single one. 
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4.5.6 Printing Recording Info 
While printing out recording data, the information will be displayed as a table containing the same fields 
as the recording list. Only fields displayed on your screen in the print preview dialog will be printed out. 

To print out data for various recordings, select these recordings in the list. Open the shortcut menu and 
click Print. Adjust printable area as shown in Figure 75. 

 
Figure 75: Print preview dialog 

Once you have adjusted printing parameters, click  in the dialog toolbar. To close the dialog, click 
Close. 
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4.5.7 Exporting Recordings  
To export recordings and related files and data, select the recordings in the list and click the Export 
option in the shortcut menu. 

To export complex recordings (see also 4.3.5): 

• If you want to export the entire recording or each simple recording it includes, select the complex 
re cording title (Fig. 76): 

 
Figure 76: Exporting the entire complex recording 

• In case you only need to export some specific parts of the complex recording, select just the 
relevant titles (Fig. 77): 

 
Figure 77: Exporting specific parts of a complex recording 
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Configure exporting options (Fig. 78). 

 
Figure 78: Exporting options 

  1 File saving mode selection 

  2 Complex recording export mode selection 

  3 File types to export 

  4 Columns displayed in the list to export 

  5 Field for specifying file name 

2 

3 

4 

5 

1 
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Select file saving mode (Fig. 79): 

List: exporting only the list containing recording info (Fig. 80). 

List and files: exporting recordings, related files and the recording list containing recording info 
and file links. 

 
Figure 79: Selecting file saving mode 

 
Figure 80: List exporting mode 
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Going forward, List and files exporting process is described (Fig. 81). 

 
Figure 81: Exporting list and files 

Tick the Join complex calls checkbox to save multiple simple recordings, included into a complex one, 
into a single audio file and keep their original order. This way, there will be a single audio file and a single 
row in the exported list for each complex recording. If you have not selected any of the simple recordings, 
they will not be merged. 

If the merge option is disabled, there will be a single audio file and a single row in the exported list for 
each simple recording. 
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Specify if you wish to export audio files (Audio checkbox). From the dropdown list, select a codec to use 
for converting audio files (Codec field, see Fig. 82). If the merge option is active, audio file conversion is 
mandatory. 

 
Figure 82: Selecting a codec 

When the merge option is disabled (Fig. 83), you can select more file types to export. 

 
Figure 83: Exporting with the merge option disabled 

Video: agent video screen capture in the original format. 

Fax: decoded fax messages in bmp format. 

Transcriptions: transcriptions in doc format obtained through the Transcriber-Word module. 
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Recognition results: full text recording recognition results in rtf, obtained through FTR Service. 

When the merge option is off, you can save the file in its original format (see Unchanged in the Codec 
filed) or convert it to a specified format. 

 

 
To save the digital signature and the watermarks embedded into the file, you have to 
export it in the original format (select the Unchanged option). 

When the merging option is enabled (Fig. 84), the related files (video recordings, decoded fax messages, 
transcriptions) are not exported (you will not be able to select them in the Exported files area). Simple 
recording recognition results will be merged into each complex recording and saved into a single file. 

 
Figure 84: Exporting with the merging option on 

A SLAVIC file (see Generate SLAVIC file checkbox) is a container storing the date on linked audio and 
video files. You can play such a file in SL2Player which synchronizes audio and video playback. You can 
generate a SLAVIC in case either an audio or a video file is missing. If both are missing (neither Audio nor 
Video checkbox is ticked), creating a SLAVIC file option is unavailable. 

In the Columns to export list (Fig. 85) there are two groups of the recording list column titles: 

Visible in recording list: columns currently displayed in the recording list. 

Other: all the rest of the columns. 
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Figure 85: Selecting columns to export 

Tick the checkboxes near the column titles to export the relevant columns. 

In the List file name field specify the file name (including the path) for the recording list file. You can 
either enter the file name manually (all non-existing folders will be created automatically) or select it 
using a typical Windows dialog after clicking . 
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The recommendable option is to save the file into an empty folder. You can save it in html, xls, xlsx, csv 
or xml formats (Fig. 86). 

 
Figure 86: Saving the file 
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To export the list and the files, click the Export button (Fig. 87). 

 
Figure 87: Exporting 

Wait until the export is complete (Fig. 88). 

 
Figure 88: Exporting status bar 
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To view the file, click Yes in the dialog that will pop up (Fig. 89). 

 
Figure 89: Export result message 

The file will be opened with an application which is used by default in your system for such file types. 
Figure 90 shows an example of an HTML file opened in a web browser. 
 

 
Figure 90: Exported list 

The list includes info on each recording, as well as links to the exported files (if List and files export mode 
was selected). According to the files linked to a recording and the file types selected in the export dialog, 
the Files column may list links to the following file types: 

• wav, sl2: audio files 

• wmv, rvf: video files 

• bmp: fax message graphic file 

• doc: transcription 

• rtf: full text recognition result 

• asr: info on keywords found with ASR Engine module 



Smart Logger II 
Working with the Application User Guide 

 

 92 Smart Logger II 
 

• slavic: a container for linked audio and video files 

In case complex recordings were exported with merging option disabled, they will have the  icon 
located on the left. Click this icon to view the info on simple recordings included in the complex ones 
(Fig. 91). 

 
Figure 91: Viewing complex recordings 

In case you selected List and files mode while exporting, a dedicated subfolder will be created for files 
within the same folder where the recording list is stored. 

 
Figure 92: Export results 

This subfolder will store audio files, videos, transcriptions and other files selected to export (Fig. 93). 
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Figure 93: Exported files 

Related files, such as web page styles, are saved into the page folder. 

 

4.5.8 Recording Color Labelling 
You can use recording color labels to mark current recording statuses. 

 

 
You can label only the recordings which were previously saved. To label a 
recording that is still in progress, use the Mark as option from the channel 
shortcut menu (see 4.1.7 Managing Channels during Recording Process). 

To mark a recording with color, select it in the list and click Mark as in the recording shortcut menu, then 
select a relevant status from the nested menu according to the color code. 
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You may also want to use the keyboard shortcuts listed in the menu (Fig. 94). 

 
Figure 94: Recording color labelling 

The recordings with a status selected will be highlighted with the relevant color (see Fig. 95). 

 
Figure 95: Recording list color code 

You can customize recording statuses and their respective color codes. For in-depth information on color 
label configuration and default color labels, please refer to 5.4 Color Labels. 
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4.5.9 Recording Transcriptions 
When transcription is enabled, Smart Logger II creates a doc file containing conversation script and 
related info. Transcribing is performed by means of the Transcriber Caesar module within the system. It 
is a software module is a Microsoft Word add-in designed for quick conversation transcription. 

To transcribe a recording, select the Open with Transcriber option from the recording shortcut menu. 
 

 
For more in-depth information on working with the transcription module, please 
refer to Transcriber Caesar Recording Transcription Module. User Guide. 

4.6 Audio and Video Playback 
4.6.1 Feature Overview 
Smart Logger II can play back the following types of data: 

• Saved conversation recordings 

• Saved video screen captures 

• Live monitored audio signals 

• Live monitored videos 

To play back a piece of data of any of the types mentioned above, use the player area. Below there is a list 
of actions you can perform using the player. For more in-depth information on each feature, please refer 
to the sections specified in the Guide Sections column. 

 

Feature Player Elements Guide Sections 

Viewing signal oscillogram and 
current playback options 

Oscillogram, timescale, 
indication elements 

4.6.2 

Managing audio and video 
playback  etc. 

4.6.3 

Special audio playback modes 
(tempo correction, noise 
reduction, etc.) 

 
4.6.4 

Viewing and managing colored 
marks 

Oscillogram 4.6.5 

Viewing audio file properties 
 

4.6.7 

Unloading an audio file from the 
player  

– 
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Feature Player Elements Guide Sections 

Configuring playback options 
 / Ctrl+Shift+O 

shortcut 

4.6.6 

Viewing file authentication 
results  

4.5.4 
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4.6.2 Player Interface 
Figure 96 shows how the Player area may generally look like. 

 
Figure 96: Player interface elements 

1 Recording ID’s or agent names 

2 Audio signal oscillogram 

3 Indication elements 

4 GUI controls for managing playback and configuring options 

There may be multiple recording ID’s in the relevant area (Fig. 96) in case multiple recordings are being 
played back. According to the system options, you can have agent name(s) here instead of recording ID’s. 

The oscillogram area (Fig. 96) includes two charts corresponding to the left and the right channel signals, 
the timescale and the colored marking option for specific fragments of the recording. Each channel refers 
to Subscriber 1 or Subscriber 2. The upper track displays the left channel signal; the lower one is for the 
right channel signal. The red vertical line which is moving while a recording is being played back locates 
the current moment of playback. 

 

 
The number of channels displayed in the oscillogram area depends on the 
recording source. Analog lines are recorded through a single channel. Recording 
through multiple grouped channels may include up to eight channels (see 
4.1.6 Multichannel Recording). 

Indication elements (Fig. 96) display the timestamp of the current playback moment and track signal 
levels in both left and right channels (for stereo signals). 

Interface elements for playback management (Fig. 96) are designed to manage audio and video playback, 
as well as to configure playback options. 

 

 
The player buttons for toggling modes change their look depending on the mode 
status. When the mode is enabled, the button will highlight blue and go sunken. 
For example, when loop playback mode is off, the relevant button for toggling it 
looks like ; when it is activated, the button changes to . 

1 2 

4 3 
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When multiple recordings are being played back at the same time (Play simultaneously option from the 
recording shortcut menu), the oscillograms will be placed in a column, one below another (Fig. 97). Use 
the checkboxes near recording ID’s or agent names to mute or unmute a recording. 

 
Figure 97: Simultaneous playback 

For simultaneous playback, actual recording time is relevant. For instance, if you selected two recordings, 
there will be a delay between playing back the first one and the other. The delay depends on the time 
period which separates the recording time of the first and the second audio file. 

To change the oscillogram scale (width), spin your mouse wheel when the Player area is active (Fig. 98). 

 
Figure 98: Scaling the oscillogram 

When zoomed in, the oscillogram area displays triangular controls in its left and right part; these controls 
enable horizontal scrolling. 

HTTPS .wmv file playback enables video caching. The caching process is displayed below the oscillogram 
(Fig. 99). 

 
Figure 99: Video file caching 

 

4.6.3 Managing Playback 
To manage audio and video playback, use the following player UI elements: 

 Start/resume playback (shortcut Ctrl+Shift+L) 

 Pause (shortcut Ctrl+Shift+L) 

  Stop (shortcut Ctrl+Shift+S); 
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Go to the previous recording in the list (if less than a 2-second fragment has been played 
back so far) or start playing the current recording from the beginning (shortcut 
Ctrl+Shift+P) 

 
Go to the next recording (shortcut Ctrl+Shift+N) 

 
Enable/disable loop playback. When this mode is on, Smart Logger II will play back a 
fragment of a recording cyclically. By default, the fragment duration is 3 s. When the player 
reaches current vertical mark position, it will start playing the fragment in question all over 
again. To specify a custom loop interval, go to player options and enter the desired value 
into the Loop duration (s) field. If the loop interval is less than the area defined by the 
current vertical mark position, Smart Logger II will start playing back the recording from 
the beginning. 
The button look changes when the mode is activated and deactivated. When enabled, the 
button is highlighted blue. The button toggles the mode once you click it. 

 
 Go to the next speech fragment (the closest to the current moment of playback). This 
button may be quite helpful when there is a long silent interval in the recording you are 
playing back and you need to quickly reach a fragment where the callers start talking again. 

  Change sound volume 
 
 

 

4.6.4 Special Modes 
While playing back the recordings, you can enable various special modes. Each mode and button for 
enabling/disabling it is described below. 

 
Automatic gain control (AGC) mode. In a playback channel, AGC is performed within the 
range specified in the AGC range field of the Player options dialog. The button look 
changes when the mode is activated and deactivated. When enabled, the button is 
highlighted blue. The button toggles the mode once you click it. 

 
 Adaptive noise reduction mode. In a playback channel, adaptive noise reduction is based 
on the values specified in Noise reduction: mode and Noise reduction: threshold fields 
located in the Player options dialog. The button look changes when the mode is 
activated and deactivated. When enabled, the button is highlighted blue. The button 
toggles the mode once you click it. 

 
Tempo correction mode. To slow down or speed up the playback tempo 
between 0.3 and 3.0 with no pitch distortion, click the  or  button 
respectively (0.1 per click). You can view the current tempo value in the box 
between these two buttons. 

You may enable or disable any of the modes described above while playback is in progress. In this case, 
audio playback options will be immediately modified. For more in-depth information on managing 
special modes, please refer to 4.6.6 Player Options. 
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4.6.5 Working with Colored Marks 
You can use oscillogram colored marks (both pre-configured and custom) to add and store the info 
related to any fragments of the recording. 

To manage colored marks display options, use the player shortcut menu which is available by right-
clicking on the timescale (Fig. 100). 

 
Figure 100: Timescale shortcut menu 

This shortcut menu includes the following elements: 

Display apps in use 

 Tick the checkbox to show which apps the callers used throughout the conversation. 

Manual label input 

Tick this checkbox to display custom labels. 

Silence 
Tick this checkbox to mark fragments where both callers say nothing.  

 

Speech 

 Tick this checkbox to display the fragments where one caller at least is talking. 

Talk at once 

 Tick the checkbox to mark out the fragments where the callers talk over one another. 

Talk over 

 Tick this checkbox to highlight the fragments where one caller interrupts the other. 

Add label 

 Allows you to create a custom mark, enter a custom comment and use it for marking the 
recordings. 
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Check all the relevant checkboxes to highlight the desired fragments on the oscillogram; untick the 
checkbox(es) in case you no longer need those fragments highlighted. 

 

 
 
 

Talk over, Silence, Talk at once and Speech marking info is saved into the file 
while the latter is being recorded. Keyword info is stored in the DB. The info 
displayed upon ticking Custom marks checkbox is saved into the DB after each 
custom mark has been added (see New mark shortcut menu option). 

You can customize color code applied to the marks (see 5.6 Assigning Color Codes for the Player). 

To add a new custom mark, right-click the oscillogram area and select the New mark option (see 
Fig. 100). In the dialog that will pop up, enter a comment and click ОК (Fig. 101). 

 
Figure 101: Entering a comment to a custom mark 

The mark will then be displayed on the oscillogram if the Custom marks checkbox in the timescale 
shortcut menu is ticked. You can see your comment when aiming your mouse pointer at the mark  
(Fig. 102). 

 
Figure 102: Viewing a custom mark on the oscillogram 

To edit the mark comment or remove the mark, right-click it and select the required option from the 
shortcut menu (Fig. 103). 

 
Figure 103: Options for editing and removing a mark 

When editing, enter a new comment as shown on Figure 101. 

When removing, you will have to confirm the action. 
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4.6.6 Player Options 

To view or modify player options, click the  button in the Player area (shortcut Ctrl+Shift+O). You 

will see the Player options dialog shown on Figure 104. 

 
Figure 104: Player options dialog 

Use the sliders to set the numeric values; the range boundaries are determined by threshold values. 

The 1. Audio options (Fig. 105) contain the fields described below. 

 
Figure 105: Audio options 
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Balance 

 Stereo signal balance in both right and left channel. A positive value shows a balance shift 
towards the right channel, while a negative value means a balance shift towards the left 
channel. 

Loop duration (s) 

 Indicates the duration if a fragment to playback when the loop playback mode is on. 

AGC range (dB) 

 Range of the input signal change used to adjust the level. 

Speech detection threshold 

 Minimum level of the signal (in dB) recognized as speech. 

Noise reduction: threshold 

 Maximum level of the signal (in dB) identified as noise. 

Noise reduction: mode 

 A mode selected from a dropdown list according to the signal source used for audio 
recording. The only options are Telephone line and Microphone. 

Start playing from (s) 

 A value in seconds indicating the timestamp from which the playback will start. Configure 
this option to avoid playing back from the very beginning (e.g. if the recording starts with 
answering machine or fax signals). 

Mixer 

 Options used to configure multichannel recording playback. 

Show comments on oscillogram 

 Use this option to enable or disable displaying comments to the custom marks. Select 
On to display the comment text when aiming the mouse pointer at the mark, and Off to 
disable the comments. 

Show absolute time on oscillogram 

 Select Off to display the time kept from the recording start; select On if you want the time 
scale to show the real time when the recording was made. 

To access the mixer options, click the  icon located to the right of the Mixer field (Fig. 106). 
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Figure 106: Mixer options 

Use mixer options to adjust signal level in both right and left channel. The first two sliders adjust track 1, 
the other two manage track 2). 

 

 
You cannot use the mixer when playing back the recordings that include more 
than 20 channels. 

You have the following controls available to adjust each channel: 

 
Enable solo mode 

 
Mute 

 

Adjust left (L) or right (R) channel signal 

 
Signal level 

 
 

 
Mixer options are applied once edited and may be modified while playback is in 
progress. 
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Enable the Solo mode to playback the channel in question only; use the Mute mode to mute it. You can 
enable the Solo mode only for a single channel; you can mute multiple channels, though. To disable 
either mode, click S or M once again. 

The 2. Saved video options (Fig. 107) include the following fields: 

 
Figure 107: Saved video options 

Enable video 

 Use this option to enable (On) or disable (Off) saved video playback. 

Enable video auto-scaling 

 Use this option to enable (On) or disable (Off) video auto-scaling, so that it may fit the 
video playback window size. 

Video size (%) 

 A percentage determining video playback window size relative to the agent’s screen 
resolution. When the Enable video auto-scaling option is on, this one is grayed out. 

The 3. Live video options (Fig. 108) include the following fields: 

 
Figure 108: Live video options 

Enable video 

 Use this option to enable (On) or disable (Off) live video playback. 

Enable video auto-scaling 

 Use this option to enable (On) or disable (Off) video auto-scaling, so that it may fit the 
video playback window size. 

Video size (%) 

 A percentage determining video playback window size relative to the agent’s screen 
resolution. When the Enable video auto-scaling option is on, this one is grayed out. 

The Player options dialog also includes the following buttons to handle changes: 

OK: Apply changes and close the dialog 

Cancel: Discard changes and close the dialog 
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Apply: Apply changes without closing the dialog 

Restore: Restore the latest saved changes 

Default: Restore default settings 

4.6.7 Viewing Audio File Properties 

To view the properties of an audio file, upload it to the player and click the  button. You will then see a 
window with the file format info (codec, sampling rate, sample bit count, stereo/mono) and the metadata 
the file contains (Fig. 109). 

 
Figure 109: Audio file properties 

 

 
Sample bit count may be displayed correctly only in case it was registered during 
the recording process. 

The metadata list shows audio file tags and their values, i.e. related audio file info. 
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4.7 VIP Customer Contact List 
4.7.1 Feature Overview 
VIP customer contact list help you store information on important call center clients. The contact list also 
enables marking VIP customer conversations in the DB. 

Below there is a list of features available when handling VIP customer information. For more in-depth 
information on each feature, please refer to the sections specified in the Guide Sections column. 

 

Feature GUI Elements Guide Sections 

Viewing and searching 
through VIP customer contact 
list  

Database area, VIP Customers tab 4.7.2 

Adding VIP customer details 
and importing them from a 
CSV file 

VIP Customers tab, Add new button 4.7.3, 4.7.4 

Editing VIP customer details Selecting a customer from the list on 
VIP Customers tab 

4.7.7 

Deleting VIP customer details VIP Customers tab, Delete option from 
the list shortcut menu 

4.7.7 

Viewing VIP customer details 
while handling a call 

Recording area, Operators tab, VIP 
column 

4.2.2 

Viewing VIP customer details 
in recording lists 

VIP column in recording lists 4.3.4, 4.7.5 

Searching for VIP customers’ 
calls 

Recording list > Filer menu option, 
Callers tab, VIP Customers area 

4.4.3, 4.7.6 
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4.7.2 Viewing VIP Customer List 
VIP Customers tab in the Database area hosts the list of the VIP customers whose details are stored 
within the system. In the right part of the tab you can edit the details of the customer you selected in the 
list (Fig. 110). 

 
Figure 110: VIP Customers tab 

VIP Customers tab details the following information on each customer: 

• Full name 

• Company name 

• Position 

• Primary phone number 

• Comment icon (if any comment is present) 

To sort the list, click the desired column. 
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To filter specific customers by their names, company names, positions, phone numbers and/or comment 
texts, start typing in the field located above the list (Fig. 111). 

 
Figure 111: Filtering VIP customers 

To clear the filter and go back to the original list, click  or just clear the field with your Backspace key. 
 

4.7.3 Adding New VIP Customer Details 
To add a new VIP customer into the database, click the Add new button located above the list. Specify 
the customer details in the Editor area (Fig. 112). 

 
Figure 112: Specifying new customer details 

 

 
Name and Phone 1 fields are mandatory (at least one phone number must be 
specified). 

To add another phone number, click  and enter it in the field that will show up (Fig. 113). 
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Figure 113: Entering a secondary phone number 

You can add more phone numbers in the same way. To delete a number, click the  button located in 
front of it. 

 

 
Each phone number in the VIP customer contact list must be unique. 

Once you click Save, the phone numbers are checked automatically and any “odd” characters are 
removed (the only relevant characters are numbers and the + character the number begins with). 

When you click Save, the VIP customer will be added to the left-hand list (Fig. 114). 

 
Figure 114: VIP customer added to the list 
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4.7.4 Importing VIP Customer Details from a CSV File 
You can import VIP customer details from a CSV file. An example of data such a file may contain is shown 
on Figure 115. 

Name;Company;Position;Comments;Phones 

Peter McBride;Awesome Solutions LLC;Implementation Engineer;Imported;+16589995|+16589997 

Mariana Rojas;Soluciones Perfectas S.L.;Regional Manager;Imported; 

Claire Guillaume;National Bank of Benin;Senior Consultant;Imported;+11111111 

Figure 115: An example of a CSV file to import 

Please note this file format has the following features: 

• Rows are delimited with a carriage return 

• Fields are delimited with a ; (semicolon) 

• The fields must appear in the following order: Name company, position, comments, phone 
numbers 

• Phone numbers are delimited with | 

• The file may or may not have a title (see the first row on Fig. 115) 

• The file must be saved as CP1251 encoding. 
 

 
The phone numbers listed in the file must not coincide with the existing numbers 
in the VIP customer contact list. 

To import a VIP customer contact list from a CSV file, click the  button located near the Create new 
button and select the Import option (Fig. 116). 

 
Figure 116: Import option 
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Select a CSV file in the Windows dialog that will show up and click Open (Fig. 117). 

 
Figure 117: Selecting a file 

You will then be notified on the import results (Fig. 118). 

 
Figure 118: Import result notification 
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VIP customer details will be added in the list (Fig. 119). 

 
Figure 119: Import results 

 

4.7.5 Viewing VIP Customer Info in the Recording List 
VIP customer conversation recordings are marked with the  icon in the VIP recording list column. To 
view VIP customer details, aim your mouse pointer at the icon (Fig. 120). In the Full name 2 field you will 
be able to see customer’s full name. 

 
Figure 120: Viewing VIP customer conversation details 

If a recording contains a non-VIP customer conversation, its VIP field is blank. 
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4.7.6 Searching Recordings by VIP Customers 
To configure a VIP customer based filter, go to the recording list and select Recording list > Filters menu 
option (see also Section 4.4.3). Once the Filtering and sorting dialog shows up, go to the Subscribers 
tab (Fig. 121). 

 
Figure 121: Configuring VIP customer filter 

Tick the VIP-Calls checkbox to filter VIP customer calls. Tick Yes to search for VIP customer conversations. 
Tick No if you do not want VIP customer conversation recordings to appear in the search results. 

Check VIP Customers to search for specific VIP customers. In the dropdown list, tick the VIP customers 
you want to appear in the recording list. Then click OK.  



Smart Logger II 
Working with the Application User Guide 

 

 115 Smart Logger II 
 

The search results will appear in the active recording list (Fig. 122). 

 
Figure 122: Search results 

 

4.7.7 Editing VIP Customer Details 
To modify VIP customer details, select the customer from the list, make necessary changes and click Save 
(same as for adding customer details, Fig. 123). 

 
Figure 123: Editing customer details 

When you aim your mouse pointer at the  icon next time, you will be shown the updated details. 
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4.7.8 Removing VIP Customer Details 
To remove VIP customer details, click Remove in the shortcut menu (Fig. 124), then confirm your action. 

 
Figure 124: Removing VIP customer profile 

After removing VIP customer details, you will be still able to see the relevant info when aiming your 
mouse pointer at the  icon in the recording list. 
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4.8 Viewing Statistics 
4.8.1 Feature Overview 
You can view visualized statistics on recordings on the Statistics tab (Fig. 125). 

 
Figure 125: Recording statistics 

The tab shows 4 charts: Number of calls, Average call duration, Call distribution by direction and Call 
distribution by channels (TOP 8). 

To hide the Statistics tab, click the  (close) button near the tab title. You can also use View > Statistics 
menu option to manage the tab display settings. 

 
  



Smart Logger II 
Working with the Application User Guide 

 

 118 Smart Logger II 
 

 

4.8.2 Number of Calls Chart 
You can see an example of a Number of calls chart on Figure 126. 

 
Figure 126: Number of calls chart 

The chart allows you to analyze absolute number (and its dynamics) of the calls logged. 

The cart shows daily call count for the current and the previous week. The Y-axis shows the number of 
calls, while the Y displays the days of the week. The reference part on the right explains the color coding 
used. 

Below the chart, you can see average number of calls per 24 hours for the current and the previous week 
(Average number of calls per day), as well as the increment percentage for the current week compared 
to last week (Trend). Positive dynamics is displayed in green, while negative dynamics is shown red. 
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4.8.3 Average Call Duration Chart 
You can see an example of an Average Call Duration (sec) chart on Figure 127. 

 
Figure 127: Average call duration chart 

The chart allows you to analyze absolute number and the dynamics of the average call duration. 

The cart shows daily average call duration for the current and the previous week. The Y-axis shows the 
duration, while the Y displays the days of the week. The reference part on the right explains the color 
coding used. 

Below the chart, you can see average call duration per 24 hours for the current and the previous week 
(Average call duration per (sec), as well as the increment percentage for the current week compared to 
last week (Trend). Positive dynamics is displayed in green, while negative dynamics is shown red. 
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4.8.4 Call Direction Breakdown Chart 
You can see an example of a Call distribution by direction chart on Figure 128. 

 
Figure 128: Call distribution by direction chart 

This chart enables you to analyze the ratio between incoming and outgoing calls for the last 5 business 
days. 

Green is for outgoing calls, blue stands for incoming. 

Each colored bar height shows relative number of incoming and outgoing calls made within one day. The 
Y-axis displays the percentage, the X shows dates. The number of calls appears on green and blue areas. 
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4.8.5 Channel Breakdown Chart 
You can see an example of a Call distribution by channels (TOP 8) chart on Figure 129. 

 
Figure 129: Channel breakdown chart 

This chart allows you to analyze the breakdown of the calls logged through different channels within the 
last 5 business days. 

The reference list below the chart explains the color coding for the channels. 

Each colored bar height shows relative number of calls received through the relevant channel within one 
day. The Y-axis displays the percentage, the X shows dates. The number of calls appears on colored areas. 
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4.9 Working with Reports 
4.9.1 Feature Overview 
You can generate different types of reports on logged phone conversations. 

For any actions related to reporting, use the Reports tab located inside the Database area. 

The tab comprises the following areas: 

  The area with the list of available reports is located on the left.  

  The area for specifying report parameters is located on the top of the screen. There you can set 
time period, operators and other parameters.  

  The report area is located below the report parameters. This area displays the report after all 
required parameters are specified.  

4.9.2 Types of Reports 
 

A report is generated based on the data collection process you can configure through filtering options. 
Reports can be grouped. Thus, phone call reports are gathered in the Calls group. The list of available 
reports depends on user rights and installed modules (Fig. 130).  

 
Figure 130: The list of available reports 

Use the report tool bar Find box to search for a specific report. 
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For more information on access rights and user account restrictions, please refer to 
Smart Logger II Multichannel Call Recording and Monitoring System. Security 
administrator guide. 

For information on default (pre-configured) reports and the relevant filters, please see the table below. 
   

Report Type Description Filters/Parameters 

Conversation data Basic info on the logged conversations 
serviced by each agent (average 
duration, silence percentage, 
agent/customer speech percentage) 

Extraction date, agents, 
groups, departments, 
locations 

Conversation duration Number of conversations with 
different duration handled by each 
agent. You can specify the conditions 
for deeming conversations as short or 
long. 

Extraction date, agents, 
groups, departments, 
locations 

Detailed conversation data Same as basic conversation info, but 
additionally includes call date and 
time, customer phone number and 
keywords 

Extraction date, agents, 
groups, departments, 
locations 

Repeat calls Statistics on customer repeat calls Extraction date 

4.9.3 Generating a Report 
To generate a report, go to the Reports tab, specify report generation parameters and click the Show 
report button. 

Specify a type of report you want to generate by selecting it from list of available reports on the left and 
specify required parameters. 

Click View report and wait until the report is generated and displayed within the same tab. 
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4.9.4 Report Export and Processing 
To work with a report, use the toolbar which consists of the following areas:  

 
 

Figure 131: Report tool bar  

1 Report navigation panel 

2 Report processing tools 

3 Zooming options 

4 Search box 

Use the report navigation panel to move through a multiple-page report. 

For report processing, you can perform the following: 

 Print report 

 Enable/disable report preview 

 Configure printing options 

 Export into a file 

In zooming options box you can specify either a percentage or a fixed size (either Page wide or Full 
page). After modifying the zooming options, click the  toolbar button. 

To search for text values the report contains, type the text into the relevant box and click Find. To move 
to the next search result, click Next. 

To export a report, click the  toolbar icon; in the dropdown list, select the format (Fig. 132) you want 
to convert the report to.  

 
Figure 132: Export formats 

1 2 3 4 
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Once you have selected the format, a Windows Save File dialog will show up. Specify the folder and the 
file name for the report to export. 

To configure printing options, click the  button located on the toolbar, then select available printing 
options in the Windows dialog that will pop up. 

To enable report preview mode, click the  toolbar button. The page will be displayed in the full size 
mode. To disable preview mode, click  again. 

To print a report, click the  button. Select a printer and configure the printing options through normal 
Windows dialogs. 
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5 Application Settings 
 

5.1 Feature Overview 
You can configure the application settings listed in the table below. For more in-depth information on 
each feature, please refer to the sections specified in the Guide Sections column. 

 

Feature GUI Elements 
Guide 
Sections 

Language settings Tools > Language settings menu option 5.2 

Basic UI settings, audio 
device settings, etc. 

Tools > Options menu, Basic tab 5.3 

Color labels used to 
mark recording status 

Tools > Options menu, Color labels tab 5.4 

Start page display 
settings 

Tools > Options menu, Start page tab 5.5 

Assigning color codes 
for the player 

Tools > Options menu, Player color codes tab 5.6 

 
 

 
The color codes assigned for the recordings and the player are the same for all 
client applications working within the system. Other settings may be configured 
differently for each Smart Logger II application instance. 

 

 

5.2 Language Settings 
To modify language settings, select Tools > Language settings menu option. A dialog shown on 
Figure 133 will pop up. 

 
Figure 133: Language settings 
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To change language and regional settings, click the flag icon. Select the relevant flag for the desired 
language; to view the language name, aim your mouse pointer at the flag (Fig. 134). 

 
Figure 134: Selecting a language and regional settings 

To apply changes, click OK. To discard changes, click Cancel. 
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5.3 Basic Settings 
To configure the basic settings, select Tools > Options menu; the General tab will be active by default 
(Figure 135). 

 
Figure 135: Basic application settings 

Use the sliders to set the values; the range boundaries are determined by threshold values. 

The tab includes the following fields: 

Maximum number of recordings in a list (thous.) 

 Maximum number of rows displayed in a recording list. 

FaxReader executable file path 

 A path to the Fax Reader executable file (in case the Fax Reader module is installed). 

FaxReader settings (mode 1) 

 Fax Reader mode 1. 

FaxReader settings (mode 2) 

 Fax Reader mode 2. 

Audio device(s) in use 

 Audio device(s) used for audio playback. You can select multiple devices from the dropwon 
list 

Download files before playing 



Smart Logger II 
Application Settings User Guide 

 

 129 Smart Logger II 
 

 This option determines whether the audio files will be copied to a temporary folder before 
they are played back. You can either enable (On) or disable (Off) this option. In case it is on, 
the recordings will be copied to a temporary folder in the %TEMP% environment variable. 
When you play back the recording once again, Smart Logger II checks whether the file has 
been already downloaded to the temporary folder; in case it has, no more downloads are 
required. Upon the next run, the application will clear the temp folder. 

Maximum number of entries in the event log 

 Maximum number of strings in the event log (Event log tab). 

Call duration threshold 

 Select the maximum duration (in seconds) that will be considered acceptable. When this 
value is exceeded, the recording duration in the agent list is highlighted red. 
To disable duration exceeded alerts, select 0. 

To apply changes, click OK. To discard changes, click Cancel. 
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5.4 Color Labels 
To view or edit recording statuses and their respective color codes, select Tools > Options menu and go 
to Color labels tab (Fig. 136). 

 
Figure 136: Color labels tab in the Options dialog 

Figure 130 shows the list of statuses and color codes used by default. For each status, you can modify the 
following: 

1. Background color. Select the desired status from the list and click the Background button, then 
select a color from the dialog that shows up. 

2. Text color. Select the desired status from the list and click the Next button, then select a color from 
the dialog that shows up. 
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To add a new status, click the Add button. In the pop-up dialog enter the new status name (see Fig. 137). 

 
Figure 137: Entering the new status name 

The new status will be shown in the list and selected by default (Fig. 138). 

 
Figure 138: New status shown in the list 

To set new status background and text color, use the same Background and Text controls you used to 
edit existing statuses. 

To rename a status, click the Rename button. You will be able to change the name using the dialog like 
the one shown on Fig. 138. 

 

 
You cannot rename the default statuses (those shown on Figure 136). 

To delete a status, hit the Delete button. 
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When you have added a new status, you will be able to select it in the recording shortcut menu (Fig. 139). 

 
Figure 139: New status in the recording shortcut menu 

To enable the new status, you can now use a new shortcut displayed to the right of the status in question 
(on Figure 139, this shortcut is Ctrl+8). 

 

 
Color label options apply to all client applications sharing the same DB. 

To apply changes, click OK. To discard changes, click Cancel. 
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5.5 Configuring the Start Page 
To configure start page display settings, click Tools > Options, then go to the Start Page tab (Fig. 140). 

 

 
You may only configure the start page if you have the Administrator privileges. 

 

 
Figure 140: Configuring start page options 

Show start page 

 If this checkbox is ticked, the Start page will be displayed within the Database area. 
The start page also features the Close and skip option you can use to hide the tab. To 
display the start page again, click the View > Start page menu option. 

RSS settings 

 An area used to configure news display settings. 
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RSS settings area is shown below (Fig. 141). 

 
Figure 141: RSS settings area 

Use default RSS 

 While this checkbox is ticked, the news will be loaded from the default RSS feed. If you 
untick the checkbox, specify the RSS feed address in the Feed address box. 

Number of items 

 Number of news items displayed on the start page. 

Update rate (min.) 

 News update rate specified in minutes. 
 
 

 

 
If you are using a proxy server to connect to the Internet, you have got to specify 
the proxy address in the system settings. To access those settings, click the Start 
button located on your desktop, then select Control Panel > Internet Options 
and specify the proxy address on the Connections tab. 

To apply changes, click OK. To discard changes, click Cancel. 
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5.6 Assigning Color Codes for the Player 
Click Tools > Options and go to the Player colors tab (Fig. 142). 

 
Figure 142: Configuring player color codes 

The tab displays the list of the marks you can place on the player oscillogram. You can assign a color code 
to each mark using the  button to the right of the colored rectangle. 

To restore the original color codes (as shown on Figure 142), click the Restore default colors link. 
 

 
Player color code options apply to all client applications sharing the same DB. 

To apply changes, click OK. To discard changes, click Cancel. 
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6 Troubleshooting 
 

6.1 Getting Help 
To get help on working with the application, select the Help > Help… menu option or press F1. In the 
PDF file that appears, navigate to the document you need to consult. 

To view the basic info on the application, click Help > Aboutе or press F11. You will then see an 
information window similar to the startup screen. This window shows the application version, 
manufacturer contact details, etc. 

You can view the same info using the start page by clicking the About and Documentation links in the 
Information area (Fig. 143). 

 
Figure 143: Start page links for getting help 

 

6.2 Submitting an Issue 
To submit an issue to technical support, select the Help > Report an issue menu option or click the 
Report an issue link on the start page. The report saving dialog will open (Fig. 144). To attach log files to 
the report, you need to export the files first, following the instructions below. In case attaching log files is 
not feasible, just skip this step and click Send email. 
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Figure 144: Saving report dialog 

A report containing log files is saved as zip. Change the report file name and specify another folder, if 
required. To do so, click the  button (Fig. 145) and select a new file path. Tick the Open the folder 
when the export is complete checkbox to view the report after it has been generated. 

 
Figure 145: Export settings 

 

 
The  icon next to the  button shows the file path is not specified or has been 
specified incorrectly. 

In the Select component(s) list select the Smart Logger II components installed on your PC that should 
be included into the report. In the Select time period area select a period for log data collection. Then, 

click . 
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In the center of the dialog you will see the list of the log files that will be included into the report 
(Fig. 146). 

 
Figure 146: Log file list 

The list details the following info on the log files: 

First entry First entry date 

Last entry Last entry date 

Component Smart Logger II software component the log file refers to 

 File size 

Path Log file path 

To exclude files from the report, use the checkboxes on the left. To select multiple list elements, use 
standard Windows features designed for managing lists (Ctrl and/or Shift keys). To select all list entries, 
press Ctrl+A. To tick or untick checkboxes, press Spacebar. 

The bottom part of the dialog shows the number and the approximate size of the files being included to 
the report. 

Click the Export button in the bottom part of the dialog and wait until all files are exported. 

Smart Logger II will create a zip bundle containing the log files and the SystemInfo.txt file that stores 
information on the OS, software installed, etc. (in case you ticked System info component prior to 
exporting). The log files are stored in dedicated folders for each component. 
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If the export operation is successful, you will see the relevant message in the bottom part of the dialog 
(Fig. 147). 

 
Figure 147: Successful export message 

To send the issue report to our technical support by email, click the Send e-mail button. An email 
template will be opened in your default email client. If you also have exported the logs, the log bundle 
will be automatically attached to the email. 

Enter the issue description, fill out all required fields and send the email. Use the contact details listed in 
the Technical Support section, if required. 
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6.3 Submitting a Feature Request 
You can submit a feature request to technical support by means of the application GUI. For that purpose, 
use the Feature request link on the start page or the Help > Feature request menu option. 

 
Figure 148: Feature request link on the start page 

An email template will be opened in your default email client. Enter the message, fill out all required fields 
and send the email. Use the contact details listed in the Technical Support section, if required. 
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Appendix А: 
Call Processing Scenarios 
 

Below you can find typical digital call processing scenarios and data interpretation results Smart Logger 
II gets without using CTI Analyzer module. 

The scenarios described below apply only to the cases when the caller used one of the following: 

• Phone receiver 

• Loudspeaker 

• Hands-free set 

The Call Direction, Internal Caller and External Caller columns show the info displayed in the recording list 
when each scenario is in progress. 

 

Scenario 
Call Direction 

 

Internal 
Caller 

 

External 
Caller 

 

Subscriber 123 picks up/hangs up the 
receiver 

 123 (empty) 

Subscriber 123 enables/disables the 
loudspeaker 

 123 (empty) 

Subscriber 123 calls the internal number 
678 

 123 678 

Subscriber 123 calls the external 
number 3258848 

 123 3258848 

Subscriber 123 calls the external 
number 456789 but cannot get any 
answer 

 123 456789 

Incoming call to 123 from the internal 
number 678 

 123 678 

Incoming call to 123 from the external 
number 3258848 

 123 3258848 

Incoming call to 123 from the internal 
number 678 transferred to 945 

 123 678#945 

Incoming call to 123 from the external 
number 3258848 transferred to 945 

 123 3258848#945 
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When a call is put on hold, the recording is not paused: the beeps during the hold are also recorded. In 
the  (Subscriber 2) column the hold is not marked with any special symbols (unlike the transfer which 
is marked with #, see the table above). 

When recording digital lines, only the external caller number is automatically identified (except E1 lines, 
where the internal callers are identified, too). 

The internal caller (agent) number is identified by the number specified for the particular recording 
channel. 

 

 
Conversation recording may be of an inappropriate quality in case a loudspeaker 
was enabled or disabled during the conversation. 

 

 
Smart Logger II starts recording an outbound call when the caller picks up the 
receiver, even if there is no connection established. A recording with an outbound 
call with no answer will include only beeps. 
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Appendix B: 
Keyboard Shortcuts 
Below you will find the keyboard shortcuts which may be helpful when performing the actions described 
in the Guide. 

Displaying dialogs: 

Ctrl+D  Display/hide Database area 

Ctrl+S  Display/hide Recording area 

Ctrl+P Display/hide Player area 

 

Channels and recording stations: 

F3 Refresh channel list 

F12 Open channel settings dialog 

 

Recording database: 

F5 Refresh recording list 

F6 Open filter configuration dialog 

Ctrl+F Open recording search by ID dialog 

Ctrl+0 Clear recording color label 

Ctrl+1 Mark the recording as To process 

Ctrl+2 Mark the recording as Pending 

Ctrl+3 Mark the recording as Processed 

Ctrl+4 Mark the recording as For review 

Ctrl+5 Mark the recording as Confirmed 

Ctrl+6 Mark the recording as Returned 

Ctrl+7 Mark the recording as Complete 
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Player: 

Ctrl+Shift+L Play/pause 

Ctrl+Shift+S Stop 

Ctrl+Shift+N Next recording 

Ctrl+Shift+P Previous recording 

Ctrl+Shift+O Show playback options 

 

Managing the application and getting help: 

F1 Show help info 

ALT+F1 Show Windows event logs 

F11 Show the About screen 

Shift+F12 Lock the application 

Ctrl+Q Exit the application 
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Terms and Abbreviations 
AGC: Automatic Gain Control. 

Recording database: a database where the information on recordings is stored; the info can be then 
viewed by client application users. 

DB: database. 

On-request transfer: File Server operating mode which enables audio file transfer only upon user 
request (by executing Play command in Smart Logger II client application). 

Recording channel: a logical entity, identified with sound data stream, which is subject to recording. 

Sound block channel: a common way of naming the channels that record sound data coming from 
analog and digital customer lines and E1 lines 

Keywords: words pronounced in a phone conversation which are searched for during conversation 
quality assessment process by customizable lexical parameters (whether the word is present in the 
conversation, when it appears, etc.). 

Customizable fields: recording list columns filled with additional info obtained from system 
modules or external software. 

Agent: an employee of a call center whose telephone calls are recorded and monitored with Smart 
Logger II. 

OS: operating system. 

Oscillogram: a curve showing any oscillating process (e.g. speech) parameters. 

Custom filter: a named set of parameters intended to search and sort entries in recordings lists. 

Resources: information on channels, agents, agent groups and departments used for selecting 
specific recordings. For instance, the system may select recordings by channel to restrict access to 
them. 

Live video: real-time video capture of an agent’s screen. 

Live conversation monitoring: real-time phone conversation monitoring. 

Live monitoring: viewing an agent’s screen in real time. 

Complex recording: a recording that consists of several phone conversation recordings. 

Recording service: a Smart Logger II software component designed to analyze the data coming 
from I/O boards and/or from other sources and to create an audio file when the recording start 
conditions are met. 
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Stored video: a video file written by video screen capture subsystem and stored on the video file 
server. 

Recording station: a computer which forms a part of Smart Logger II infrastructure and houses one 
of the recording modules (recording service and the source). 

Transfer: an action of transferring a call to another caller. 

Fax message: signal recording using image transfer technology through PSTN; the recording is 
subject to decoding (source image recovery). 

Recording: an audio file containing phone conversation data and its metadata (duration, start time, 
caller number). 

Hold: an action of putting a call on hold. 

Recording details: all relevant information on a particular recording (its ID, duration, subscriber info, 
etc.) stored in the recording database. 

CTI: Computer Telephony Integration, a common name for any technology that allows interactions 
on a telephone and a computer to be integrated or coordinated. 

E1: a digital data transmission carrier. 

MAC address: Media Access Control address, a unique identifier assigned to network interfaces for 
communications on the physical network segment. 

RTP: Real-time Transport Protocol, a standardized packet format for delivering audio and video over 
IP networks. 

SIP: Session Initiation Protocol, an IETF-defined signaling protocol widely used for controlling 
communication sessions such as voice and video calls over Internet Protocol (IP). 

SLAVIC: SmartLogger Audio Video Information Container, a file format for storing information on 
agent conversation recording and the relevant video screen capture. 

SMTP: Simple Mail Transfer Protocol, a standard for email transmission on a computer network. 

SSL: Secure Sockets Layer, an encryption protocol which enables a secure connection between 
client and server. 

TCP/IP: Transmission Control Protocol/Internet Protocol, a protocol stack of various network layers 
used in computer networks. 

VoIP: Voice over IP, a technology for making telephone calls over the Internet, converting speech 
sounds into binary data. 

VoIP channel: a channel used for recording sound data transferred across the network by means of 
VoIP technologies. 
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Index 
 

Basics 
Recording database 9, 70 

Event log 18 

Recording channel 10, 24 

Client application 10, 126 

Recording module 10, 30 

Player 35, 95, 135 

Live conversation monitoring 9, 26, 34, 40 

Live video 9, 105 

Complex recording 53, 67, 75, 82 

Recording service 10, 47 

Recording station 10, 23, 53, 71  

Start page 18, 65, 133, 136 

Recording details 70 

 

Main Menu Options 
File > Refresh channel list 26 

File > Change connection settings 14 

File > Exit 14 

View > Database 20 

View > Recording 20 

View > Player 20 

View > Event log 20 

View > Statistics 20, 133 

View > Start page 20, 133 

View > Active channels first 28 

View > Sort channels 27 

Recording list > Refresh recording list 68 

Recording list > Filter configuration 61 

Recording channels > Channel list 24 

Access right restriction > Access right restriction 13 
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Access right restriction > Lock Smart Logger II 13 

Tools > Language settings 126 

Tools > Options 130–135 

Help > Help 136 

Help > Report an issue 136 

Help > Feature request 140 

Help > About 136 

 

Shortcut Menu Options 
Channel shortcut menu: 

• Stop recording 33 

• Resume recording 33 

• Enable audio recording 29 

• Disable audio recording 30, 32 

• Enable video recording 29 

• Disable video recording 32 

• Enable live monitoring 34 

• Disable live monitoring 35 

• Recording mode 29 

• Recording options 30 

• Merge channels 31 

• Mark as 33 

• Split channels 31 

 

Recording shortcut menu: 

• Clear filter 66, 68 

• Recording details 70 

• Play 74 

• Delete 80 

• Open with Transcriber 95 

• Export 82 

• Mark as 93 
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Shortcut menu for multiple recordings: 

Play one by one 75 

Play simultaneously 75, 98 

Delete selected 80 

 

Recording list shortcut menu: 

Customize grid 55 

 

Agent list shortcut menu: 

Enable live monitoring 41 

Disable live monitoring 42 

Customize grid 43 

Mark as 42 

Player shortcut menu: 

 

Dialogs 
User login 12 

Grid customization 43, 55 

Filtering and sorting 62 

Search recordings by ID 68 

Recording details 71 

Export recording list 82 

Text mark comment 101 

Player options 102 

Language settings 126 

Options 130–135 

Saving report for technical support 136

New label 42 
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