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Note to Customer 

 

Before getting started, please read this User Guide carefully. The User Guide will allow you to effectively use all software features and 
functions. 

Should you have any questions regarding software operation and use, do not hesitate to contact STC Support or local resellers. 

 
Technical Support: 
 
Saint Petersburg 
Email: support@speechpro.com 
Phone: +7 (812) 325-8848  
Fax:       +7 (812) 327-9297 
 

Moscow 
Email: kdo@speechpro.com 
Phone: +7 (495) 623-5505  
Fax:       +7 (495) 623-5505 
 

STC Support web portal: http://speechpro.com/support_form 
 
When contacting Technical Support, please include the following details into your call/ticket: 

• Clear issue description. 

• Product name and model and version. 

• Software name and version. 

• PC configuration. 

• Operating system name and version. 

The manufacturer retains the right to issue amendments to this User Guide following any improvements to software design without any prior 
notification. 

Any such amendments will be published in a new User Guide edition, as well as on STC website: http://www.speechpro.com. 

http://speechpro.com/support_form�
http://www.speechpro.com/�
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INTRODUCTION 
The present Guide describes audio restoration and noise cancellation software Sound Cleaner II. 

The Guide does not substitute any academic or reference books, operating system manuals or other information sources. 

Typographic Conventions 
The following typographic conventions are used in this Guide: 
 

Formatting Description 

Normal Is used for body text. 

Italic Is used to highlight new terms. 

Bold Is used to highlight software components, as well as interface elements (headings, buttons, etc.). 

Bold Italics Is used for file names and file paths. 

Underlined blue Is used for hyperlinks. 

Menu selection is marked with the > symbol (Menu > Option). It means you should click Menu first and then select Option. 
 

Below there is a notification layout used in the Guide according to notification severity level: 
 

 
Links to other documents in the body text. 

 
 

 
Notes, important notices and instructions obligatory for fulfilling. 

 
 

 

Not fulfilling these requirements may potentially lead to hardware and software malfunctions and 

failures. 
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Trademarks 
Windows®, Windows® 7 and Windows® 8 are trademarks of Microsoft® Corporation in the USA and/or other regions. 

Adobe, Adobe®, Acrobat® logos, Acrobat, Adobe PDF and Reader logos are trademarks of Adobe Systems Incorporated in the USA and/or 

other regions. 

Other company names and product names mentioned in this document are the property of their respective owners. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

No part of this Guide may be reproduced or transmitted in any form or by any means, electronic or mechanical or translated into any language without prior written 
permission of Speech Technology Center. 
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1  GENERAL INFORMATION 
1.1 About the Application 

Application name Sound Cleaner II Comprehensive Audio Restoration Software STC-S630 

Manufacturer STC, Ltd. 

Address 4a Ul. Krasutskogo, 196084, St. Petersburg, Russia 

Phone +7 (812) 325-88-48 

Fax +7 (812) 327-92-97 

Email support@speechpro.com 
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2  APPLICATION OVERVIEW 
2.1 Overview 
Sound Cleaner II is intended for noise reduction, audio quality and voice intelligibility improvement. 

The software performs the following tasks: 

• Opens audio and video files. 

• Improves audio quality and voice intelligibility. 

• Enables identifying literal content of low-quality speech recordings. 

• Automatically creates text reports about speech signal processing. 

The following noise reduction filters are implemented in the application: 

1. STC Auto Filter 

2. Broadband Noise Filter 

3. Tone Suppressor 

4. Click Suppressor 

5. Inverse Filter 

6. DTMF Suppressor 

7. Cellphone Noise Filter 

8. Reverb Suppressor 

9. Clip Restorer 

10. Dynamic Range Control 

11. Reference Noise Canceller 

12. Reference Noise Suppressor 

13. Equalizer 

14. Amplifier 
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2.2 Application Features 
Sound Cleaner II performs the following functions: 

1. Opens audio files and audio tracks of different formats. 

2. Reduces noise and distortions of various types including: 

• Stationary and slowly varying additive multi-component narrowband (polyharmonic) and broadband noise 
• Slowly varying amplitude-frequency distortion (audio recording/transmission channel frequency-response ripple) 
• Reverberation 
• Impulse noise 
• Cell phone noise 
• Dual-tone multi-frequency signaling (DTMF) 
• Audio level difference 
• Waveform restoration of signals recorded with amplitude overload 
• Additive noise in two-channel audio stream 

3. Organizes noise reduction filters into units that enables arranging filtration sequences. 

4. Saves filter settings and its sequence as a file.  

5. Enables adjusting filter settings manually observing the waveform and instantaneous spectrum before and after processing. 

6. Changes playback speed without distortion of the absolute pitch. 

7. Enables loop playback of the entire signal, signal fragments or from the current playback indicator position. 

8. Enables creating recording transcriptions using a built-in text editor. 

9. Automatically saves processing history. 

10. Creates reports about performed actions in the HTML format, which contain information about the organization, audio file and user. It 

also includes images of source and processed signal waveforms, their spectrums, information about applied filters and their settings, 

all file alterations and recording transcriptions. 

11. Saves filter settings as presets. 

12. Automatically synchronizes main signal and asynchronous reference channel for further processing. 

13. Connects Sound Cleaner II as VST plugin (of VST3 format) for other sound editors (Adobe Audition, Sound Forge, Wave Lab, etc.) as 

well as for the digital audio workstation Pro Tools (only for Windows). 
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3  GETTING STARTED 
3.1 Hardware Requirements 
Minimum system requirements for Sound Cleaner II are as follows: 

• Processor: 2.66 GHz Intel® Core™ 2 Duo. 

• 1 GB of free disk space. 

• Microsoft® Windows® 7 / 8 Professional or above; Mac OS 10.8.5 or higher (64 bit). 

• RAM: 1 GB or higher. 

• CD-ROM drive 48× (if the software is delivered on CD). 

• SVGA video card and monitor. 

• Screen resolution: 1024 x 768, 32 bits. 

• Keyboard and mouse. 

• Speakers and/or headphones. 
 

 
To activate the software online, the Internet connection is required. 

 
 

3.2 Delivery Set 
Sound Cleaner II is available for purchase on CD, or it can be also downloaded from our website. 

The CD version comes with hardware license key. The key enables using the application on various PCs. 
 

 
Hardware license key requires one free 2.0 USB port. 

If you would like to download Sound Cleaner II, you will get an email with a link to our website and an activation key. In this case the 

software can be activated on one PC only. 
 

 
To reactivate the application (when reinstalling OS), please contact our technical support. 
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3.3 Installing the Application 
 

 

To install and activate Sound Cleaner II on Microsoft Windows 7 / 8, Mac OS, you must have 
an Administrator Privilege. 

 

 
Sound Cleaner II cannot be installed on virtual machines. 

 

To install the software, launch the Setup.exe file located in the root directory. Select the installation language. 

In case software prerequisites are not installed on your PC, installation wizard will suggest installing them (Fig. 1). 

To install the prerequisites, click Install and wait until the installation is complete. To exit the prerequisites installation, click Exit.  

If prerequisites have already been installed, the dialog will not appear. 
 

 

Installing Sound Cleaner II for the first time, software will operate in a trial mode before 
activation. The trial license is valid for 30 days from the first launch and has the following 
functional limitations: it operates on the Preview mode; the user can process only 30 seconds 
of each recording; the result cannot be saved. 

 

 
Figure 1: Installing prerequisites. 
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After the prerequisites have been installed, you will see the installation wizard dialog box. Follow the instructions to complete the installation. 

After the installation is complete, you will see the message box informing that the Sound Cleaner II has been successfully installed. Click Exit. 

To run the application, click Start > All Programs > Speech Technology Center > Sound Cleaner II. 

3.3.1 Installation Troubleshooting 
If a Sentinel SL key has already been used on the PC before installing Sound Cleaner II, an error message may appear. Stop HASP Loader 

and restart the installation. 

To stop HASP Loader, use one of the following methods: 

1. Run the net stop "HASP Loader" command in the command prompt. 

2. Stop the service using OS applications: 

• In the Start menu select Control Panel > Administrative Tools > Services. 

• Right-click on the HASP Loader and select Stop. 
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3.4 License Activation 
 

 

To activate the Sound Cleaner II license on Microsoft Windows 7 / 8 or Mac OS, a user must 
have an Administrator Privilege. 

The product is delivered with the Sound Cleaner II Product Key. 

After installation, the software is available in the demo mode. When you start the program, the activation screen appears (Fig. 2). Follow the 

steps described in Sections Online Activation, Offline Activation or Activation on Mac OS to activate your license. 
 

If you have the demo version installed on your PC, you can purchase the license from the manufacturer website. Click the Purchase Now 

button in the activation screen. You will be redirected to STC website Sound Cleaner II page. Click Buy. Select either box or electronic version 

and click Order. You will be prompted to complete the purchase form. Make sure to fill in the fields and click Order. Our product lead will 

send you your personal Product key that you will need for software activation. 

 
Figure 2: Initial activation screen. 
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3.4.1 Online Activation 
 

 
Make sure neither firewall nor antivirus is blocking Sound Cleaner II during activation. 

 

 

Before activating Sound Cleaner II activation, make sure the latest Java version is installed on 
your PC. Add web portal to the Exception Site List (for more information, refer to the Web 
Portal Content Is Not Displayed section. 

 

If your PC is connected to the Internet, click the Activate button in the activation screen. You will be redirected to the Sentinel online 

activation page on the STC website. Enter the Product Key and click the Login button (Fig. 3). 

 
Figure 3: Entering the product activation code. 
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Enter your personal data and click Save (Fig. 4 ). 
 

 
Figure 4: Entering personal data. 
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Then click the Online Activation button (Fig. 5) to go to the next activation page and complete the process. 

 
Figure 5: Choosing online or offline activation. 
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If you already have one or more security keys on your PC installed, select the New Key option 
in key activation dialog window (Fig. 6). 

 

 

 
Figure 6: Selecting protection key. 
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3.4.2 Offline Activation 

If your PC is not connected to the Internet, click the Activate Offline button in the activation screen (Fig. 2). A special utility for c2v file 
generation will show up (Fig. 7). 
 

 

Open the Collect Status Information tab and tick the Installation of new protection key 
radio button (Fig. 7). 

 

  
Figure 7: The Collect Status Information tab of the activation utility. 

 
The utility will generate a c2v file. Save this file on your PC. 
Take the generated file to a computer having Internet connection and go to http://activation.speechpro.com:8080/ems/customerLogin.html. 
  

http://activation.speechpro.com:8080/ems/customerlogin.html�
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Enter the Product Key you have received and click Login (Fig. 8). For more information on how to receive your Product key, refer to Section 
License Activation. 

 
Figure 8: Entering the product activation code. 
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Enter your personal data and click Save (Fig. 9). 
 

 
Figure 9: Entering personal data. 
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Click Offline Activation in the top right-hand corner of the screen (Fig. 10). 
 

 
Figure 10: Selecting offline activation. 
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In the next screen, upload a previously created c2v file and click Generate (Fig. 11). 
 

 
Figure 11: License generation screen. 
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 Once a v2c file is generated, a relevant screen will show up (Fig. 12). Click Download V2C File.  
 

 
Figure 12: The v2c file is generated successfully. 
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A dialog will show up. Select Save File and click OK (Fig. 13). 
 

 
Figure 13: Saving a V2C file. 

Take this file back to the PC where c2v file has been generated and apply it. To do so, switch to Apply License File tab of the dialog (Fig. 14). 
Click the “…” button to browse for your v2c file. Once the file is loaded, click Apply Update. 
 

 
Figure 14: Uploading the v2c file. 
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Once the update is complete successfully, the Update written successfully message will show up.  

 
Figure 15: Update written successfully.  

 

After the activation process is completed, the application main screen will show up. 
If you do not activate the software license, the application will operate in the trial mode. You can activate the license later using the initial 
activation screen. 
 

 

After the activation is finished, please restart the application to remove the trial mode 
restrictions. 
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3.4.3 Activation on Mac OS 

 
On Mac OS only offline activation is available. 

 

The activation process for Mac OS does not differ much from one for Microsoft® Windows® 7 / 8. Working on Mac OS, the activation utility 

dialog has a slightly different view. Instead of radio buttons in the activation dialog, there is the Key ID field, which contains the software 

license key identifier (Fig. 16). 

 
Figure 16: The Collect Status Information tab of the activation utility on Mac OS. 
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The utility automatically inserts the software license key identifier into that field. If it was not entered by default, please enter the identifier 

manually. To do so, click this hyperlink http://localhost:1947/_int_/devices.html. A web interface of the software license key management 

service will be opened in your browser. There you have to select a local SL key and click Products in the Actions column (Fig. 17). 

 
Figure 17: Table of the activation keys. 

You will be directed to the page with all STC products, which the selected license key is valid for. The key identifier will be located on the top 

of the page in the Key field (Fig. 18). 

 
Figure 18: Activation key details. 

Please, enter this ID into the Key ID field of the activation utility window (it can be entered manually, or you can copy it from the browser 

address bar after “haspid=”). 

Follow the activation process described in the 3.4.2 section. 

http://localhost:1947/_int_/devices.html�
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4  LICENSE ACTIVATION TROUBLESHOOTING 

4.1  Web Portal Content Is Not Displayed 
Customer Portal content may be blocked by Java. In this case, add the portal to Java exception list by doing the following:  

1. Close all open browsers. 

2. Go to  Start > Control Panel. 

3. Once in the Control Panel, type Java in the search box (Fig. 19). Once you have got the search results, click the Java link. 

  
Figure 19: Control Panel dialog. 
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In the Java Control Panel dialog that will open (Fig. 20), open the Security tab and click Edit Site List. 

 
Figure 20: Java Control Panel. 
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In the Exception Site List dialog (Fig. 21), click Add. Type http://activation.speechpro.com:8080 into the empty string and click OK. 
 

 
Figure 21: Exception Site List dialog. 

 

In the Security Warning – HTTP Location dialog (Fig. 22), click Continue. 
 

 
Figure 22: Security Warning – HTTP Location dialog. 

 

In the Java Control Panel dialog (Fig. 20), click OK. 

Finally, re-open your browser and try to login to the Customer Portal again. 
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4.2 Java Applet Cannot Run 
 

If Java is not installed on your PC (or one of the previous versions is installed), you will be prompted to install or update your Java version 

(Figure 23). Click OK and follow the guidelines. 
 

 
Figure 23: Downloading latest Java version. 

4.3 Error during Activation 
 

 

In case Java is already installed on your PC, an error may occur while updating it to version 6. This can happen if the system fails to detect the 

following dll files: hasp_windows_71511.dll and HASPJava.dll. You will be prompted to download these files (Figure 24). Make sure these 

files are installed in C:\Program Files (x86)\Java\jre7\bin. 

 
Figure 24: Downloading dll files. 

 

 

In case the required files are installed and located correctly and the error message still shows 
up, make sure you run your web browser with Administrator Privilege. 
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4.4  Vendor Libraries Not Found 
 

While applying a v2c file, you may get the Vendor lib cannot be found error message. In this case, request a new up-to-date HASP Driver 
version from STC Technical Support. 
 

4.5  Cannot Take a Key Snapshot 
While taking the key snapshot for remote update, you may get the following error message: Could not access Sentinel protection key. 
Could not find appropriate Sentinel protection key. This means the system has not found any key manufactured by STC on this computer. 

To make sure it is really so, open Sentinel Admin Control Center. Open your browser and type http://localhost:1947 into the address bar. 

Once there, select Sentinel Keys (Fig. 25). 
 

 
Figure 25: Sentinel Keys page 

 

In the Location column, find all keys marked as Local. View the code of these keys displayed in the Vendor column. STC code is 71511. If 
other code is displayed here, you will not be able to update these keys with the RUS Branding utility. 
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5  BASIC CONCEPTS 
5.1 Creating a Scheme 
To process a signal, you can create a so called scheme, which is a sequence of filters with particular adjustments. 

Each filter in the sequence alters the signal in accordance with its adjustments and then passes it to the next filter in the scheme. So the noise 

reduction filters are organized in units and realize successive signal processing. 

The number of filters in the scheme is unlimited. 

The first step is to upload a file with the signal for processing. This signal is called the source signal. 

After uploading, the source signal becomes a signal in process, which is displayed on the screen as a waveform. So, at first, before any 

alterations are made, the working signal and the signal in process are the same. 
 

5.2 Preview Mode 
The Preview mode is a tool that enables checking the results of performed alterations without applying them to a signal. 

When the Preview mode is on, the waveform of filtered signal is displayed on top of the source signal and has different color. Working in this 

mode you are able to playback a selected signal part with filters applied. The signal waveform will be changed according to applied changes 

and visualized gradually. Also, if the Preview mode is on, all changes in the scheme are immediately displayed on the preview waveform. 

After the Preview mode is switched off, the preview waveform will stay visible until you apply selected filters to the signal (the signal in 

process will be changed according to the chosen filters and their settings), or until the Preview mode is switched on again (in this case the 

preview waveform will be rendered all over again). 

In the Preview mode you can add or remove filters, change their settings. All alterations will be displayed on the preview waveform right 

away. 

Both waveforms, the one of the source signal and the one of the signal is process, are synchronized in time. 
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5.3 Arranging Filters 
The user selects filters needed for a signal processing and arranges them in sequences by listening to the signal and relying on the signal 

waveform. 

There are two ways to display filter schemes in the main screen: Complete scheme (each filter is displayed in a separate dialog together with 

its settings), or Navigation scheme (filters are displayed as icons). 

Both navigation and complete scheme areas are divided into fields for right and for left channels. Generally the application processes left and 

right channels of a stereo signal separately. Depending on what channel needs to be processed (left or right), drag a filter you would like to 

apply to the left or right channel field. To apply a filter to both channels, select All Channels in the filter shortcut menu. The filter intended to 

process both channels will be collocated in the middle between left and right channels. 
 

 

The Equalizer filter cannot be applied to both channels at the same time; it has to be applied 
separately to left and right channels. 

 
 

5.4 Saving Files and Schemes 
Using the Preview mode you can pick and adjust filters before applying then to a signal. If you are satisfied with the result, you can apply 

selected filters to the signal in process or one of its parts and save processed signal as a file. 

Created filter sequence or filtration scheme can also be saved as a file for later use. In this case filtration sequence and settings in the scheme 

are saved as well. 

A filtration scheme can be saved as a preset which is a scheme with an audio file as an example attached. 

To make Sound Cleaner II more user friendly, there are several build-in presets in the application. Each preset has an attached audio file to 

demonstrate filter adjustments for every particular case. 
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6  APPLICATION INTERFACE 
6.1 Main Screen Overview 

 
Figure 26: Sound Cleaner II main window. 

The Sound Cleaner II main screen is shown on the Figure 26. 

Message box 

Disabled filter 

Enabled filter 
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The application main screen consists of the following areas: 

1. Main menu 

2. Data area with signal waveform 

3. Status bar 

4. Playback control panel 

5. Filtration Scheme panel with three tabs: Filters, Presets and History 

6. Navigation scheme with filter icons 

7. Complete scheme with filter dialogs 
 

At the right side of the status bar there is an icon that is used for displaying error messages (for more information, please refer to the 

6.3 Status Bar section). 

All filter dialogs are of the fixed size, except the Equalizer dialog, and cannot be changed. 

It is also possible to open the Transcriber module, which will be located below the playback control panel (for more information, please refer 

to the 13 TEXT TRANSCRIPTION section). 
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6.2 Playback Control Panel 
The playback control panel is used for playing back and processing of audio files (Fig. 26, pos. 4). 

While a file is played back, the current playback time is displayed at the left side of the control panel. 

Playback control buttons are used to perform the following functions: 

Button Description 

 
Plays back the selected file. 

 
Pauses audio file playback. 

 
Stops audio file playback. 

 Enables/disables the Preview mode. 

 
Enables/disables the Loop playback mode. 

 
Applies filter settings to an audio file. 

 /  Mutes/restores volume in each channel. 

 /  Synchronizes volume of both channels. 

The Filtering and Preview buttons are disabled until the user begins to work with filters. 

Buttons  and  replace each other. 
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6.2.1 Playback Control 
You can control playback/pause using one of the following ways: 

• Playback control panel. 
• Main menu options. 
• Pressing the Space key. 

 

When the Transcriber module window is open, the Space key is not applicable regardless of 

which window is active. In this case use Ctrl+Space shortcut. 
 

If the playback indicator is located on the waveform or a certain part of signal waveform is selected, the playback will start from the indicator 

position or from the beginning of the selected fragment. 

 

Sound Cleaner II works with the default sound card. If you would like the application to work 
with a new sound card, restart Sound Cleaner II. 
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6.3 Status Bar 
The status bar is located below the signal waveform. 

 
Figure 27: Main screen status bar. 

The status bar displays the following audio file data: 

• Bit depth. 

• Sampling rate. 

• Number of channels: mono or stereo. 

• Total recording duration: hh : mm : ss . ms. 

• Beginning of the selected fragment. 

• End of the selected fragment. 

• Duration of the selected fragment: [hh : mm : ss . ms]. 

The message icon  displays notifications. 

To see previously displayed messages, use one of the following ways: 

1. Left click on the icon. 

2. Select the View > Show Notify List main menu option. 
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7  PROCESSING AUDIO FILES 
7.1 Opening Audio Files 
Most of the commonly used audio file formats are supported by the application, for example: WAV, MP3, WMA, AVI, OGG, AIFF, FLAC, etc. 

 

A complete list of supported formats can be found on the website: 

http://ffmpeg.org/general.html. 
 

To open a file, follow use one of the following ways: 

1. Select the File > Open... main menu option or press Ctrl+O. You can listen to the signals from the files before loading them. 

2. Select a file and click Open in the Open File dialog. 

The application will load the selected file and display its waveform the data area (Fig. 28). 

The file data will be displayed in the status bar below the waveform. 

  

http://ffmpeg.org/general.html�
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7.2 Data Area Overview 
7.2.1 Data Area 
The data area consists of the following areas (Fig. 28): 

1 Tab of the opened file. 

2 Scaling icons. 

3 Navigation waveform. 

4 Full-size waveform. 

5 Horizontal scroll bar. 

 
Figure 28: Data area. 
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7.2.2 Opened File Tab 
This tab shows the name of the opened audio file. It also contains the  button to close this tab. 

Loading one more file, a new tab appears in the data area and becomes an active tab. 

To activate another file tab, left click its title. 

7.2.3 Navigation Waveform 
Sometimes a signal waveform is too long, and the data area displays only its part. In this case the navigation waveform becomes a really 

useful tool.  

The navigation waveform visualizes the signal and highlights a part of the signal, which is displayed in the data area at the moment. It also 

displays all alteration performed with the signal. 

Using the navigation waveform you can change the size of the signal waveform fragment displayed in the data area (Fig. 29, a). To do so, 

place the cursor on the edge of the highlighted area in the navigation waveform until you see the bidirectional arrow. Keeping the left mouse 

button pressed drag the border. The horizontal scroll box will change in size as well. 

You can also navigate the waveform. To do so, place the cursor on the highlighted area of the navigation waveform until it changes its shape 

to an open palm. Keeping the left mouse button pressed move the highlighted area (Fig. 29, b). Thus, the data area will display the part of the 

signal highlighted on the navigation waveform. 

The navigation waveform enables defying the highlighted area, which will be displayed in the data area. To do so, place the cursor on the 

navigation waveform, where you would like the highlighted area to begin. Keeping the left mouse button pressed, drag the cursor to the 

point, where you would like the highlighted area to end (Fig. 29, c). The horizontal scroll box will change in size as well. 
 

a)   b)   c)  
Figure 29. Changing size (a), moving the highlighted area (b) and selecting the highlighted area (c) of the navigation waveform 

 

For scrolling you can also place the cursor on the horizontal or vertical scroll bar, press Ctrl 
(Cmd for Mac OS) and rotate the mouse wheel. 
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7.2.4 Signal Waveform 
The signal waveform enables observing the entire signal or any its parts. 

The horizontal axis shows the current time from the beginning of the signal in seconds, and the vertical one displays the signal amplitude in 

samples. 

Place the cursor on the horizontal or vertical scale and rotate the mouse wheel to change the data area. 

To display the entire signal horizontally, use one of the following ways: 

1. Select the View > Horizontal auto-zoom menu option. 

2. Press F8. 

3. Click the  icon located above the navigation waveform. 
 

To display the entire signal vertically, use one of the following ways: 

1. Select the View > Vertical auto-zoom menu option. 

2. Press F7. 

3. Click the  icon above the navigation waveform. 
 

To display amplitude in dB, use one of the following ways: 

1. Select the View > In dB menu option. 

2. Select the In dB option of the vertical scale context menu. 

3. Press F5. 
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7.3 Selecting Signal Area 
To select a signal area, follow these steps: 

1. Place the cursor on the waveform, where you would like the selected area to begin. 

2. Press the left mouse button and drag the cursor to the point, where you would like the selected area to end. 

3. Release the left mouse button. 

The selected area will be highlighted with a different color and bounded with two vertical dotted lines (Fig. 30, a). 

a)    b)  

Figure 30: Shifting the selected area borders (a) and the vertical cursor (b). 

To move the selected area borders, follow these steps: 

1. Place the cursor on the border line until it takes shape of the bidirectional (as shown on the Figure 30, a). 

2. Keep the left mouse button pressed and drag the border to the point, where you would like the selected area to end. 

You can move the vertical cursor the same way (Fig. 30, b). 
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7.4 Data Editing 
There are several options to edit a signal in the application: 

• Undo: cancels the last performed action. 

• Redo: restores the previously undone action. 

• Delete: removes the selected area of a signal. 

• Trim: removes all other data except the selected area. 

Use the Signal Shift Left menu option or Ctrl+Shift+Left shortcut to shift the entire signal to the left along the horizontal scale by the size of 
the selected area. 

Use the Signal Shift Right menu option or Ctrl+Shift+Rgiht shortcut to shift the entire signal to the right along the horizontal scale by the 
size of the selected area. 

7.4.1 Dividing Stereo Signals 
To divide a stereo signal into two mono signals, open a stereo file and select Edit > Divide stereo to two mono or press Ctrl+2. 

Two separate mono signals extracted from the left and right channels of the original stereo file will appear in new tabs (one new tab for each 
signal) (Fig. 31). You can save signals from left and right channels as files. To do so, click on the tab with signal you would like to save and then 
save this signal as file (to learn more about saving files, please refer to the 7.8 Saving Audio Files section). 

 
Figure 31: Data area. Original stereo file tab, left and right channel tabs. 
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7.4.2 Creating a Reference Channel 
One of the most distinctive features of Sound Cleaner II is the stereo filtration using the asynchronous reference channel. Asynchronous 
filtering can be applied when a single-channel recording made through a microphone contains a speech signal distorted by a noise, a piece of 
music for example. If the noise is a known piece of music or other media, you can obtain it from an external source, for example, a CD, hard 
disk or the Internet. 

The main channel that contains the voice signal and the noise (for example, music), is called the source recording. 

The reference channel is the “pure” noise (music) obtained from a separate source (for example, a CD). 

Asynchronous filtering consists of two successive processes: 

1. Synchronization of the source recording and the reference signal. 

2. Noise suppression by means of stereo filtering. 

Synchronization includes the following steps: 

1. Equalizing the sampling rates (done automatically). 

2. Marking the approximate beginning of speech in the source recording and the corresponding point in the reference signal (done manually). 

3. Marking the approximate end of speech in the source recording and the corresponding point in the reference signal (done manually). 

4. Matching of the exact beginning and end of speech (done automatically). 

To perform stereo filtration using the asynchronous reference channel, click Edit > Create reference channel or press F11. 

 

The software does not support the processing of stereo and 32-bit signals when creating the 

reference channel. The maximum duration of a processed signal cannot be more than 30 

minutes. 
 

 

While creating a reference channel, the signal editing operations are unavailable (except Shift 
signal left/right options). 

 

A new Reference Channel tab containing two empty areas will appear. The upper area is for the source recording and the lower one is for the 
reference signal (Fig. 32). 

1. Load the source recording into the upper area (for the main channel): 
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• Click the Browse... button (Fig. 32). 

• Select a signal in the Open File dialog. 

The source recording will be displayed in the upper area. On the right you will see information about the loaded signal: file name, sample rate 
and duration. 

2. Click Next to proceed. 

 

Before opening a file, make sure it meets the requirements for minimum duration (22 s with sample 

rate of 4000 Hz, 18 s with sample rate of 8000 Hz, 16 s with sample rate of 11 025 Hz and 11 s with 

sample rate of 22 050 Hz). 

 

 
Figure 32: Creating the reference channel.  
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3. Load the reference signal to the lower window of the reference channel (Fig. 33). 

 
After loading the reference channel, the source recording cannot be changed. 

The reference signal will be displayed in the lower area. On the right, you will see information about the loaded signal: file name, sample rate 
and duration. 
 

4. Click Next to proceed. 

 
Figure 33: Loading the source recording and the reference signal. 

5. Mark the beginning of speech on the main channel waveform (Fig. 34). 

There is no need to mark the exact point of the beginning of speech; you can set the mark with the accuracy of 0.5-1 s. 

6. Find the corresponding point in the reference signal and set the mark (Fig. 34). 
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Figure 34: Placing marks at the beginning of the signals. 

7. Click Next to proceed. 

 

Usually it is not very difficult to find the beginning of speech in the main channel (speech with 
noise). It is much more difficult to find the respective point in the reference channel. Short, 
similar to each other waveform parts can be useful in this case. To find appropriate part (for 
instance, a song that is considered a noise may include long similar breaks, so it is not easy to 
understand what part corresponds to the speech beginning), that is why you might need to 
scroll the reference channel waveform and listen to the different fragments several times. 

 
 

8. Listen to the end of the source recording, observe its waveform along the time line and place the speech end mark. Then find the 

corresponding point in the reference signal and set the speech end mark (Fig. 35). 

9. Click Next to proceed. 
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Figure 35: Placing the marks at the end of the signals. 

 

10. Synchronize the beginning and end of the fragments of the source recording and reference signals. If you are not satisfied with the 

result, go back and reset the marks. If you that the problem lies with the automatic adjustment, uncheck the Automatically tune 

border marks box and the manually placed marks will be used. 
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11. Click Next to process the data. 

 
Figure 36: Performing the precise signal synchronization. 
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12. After the synchronization is finished and the respective fragments are aligned correctly, click Finish to save the result of this operation 

to a stereo file. 

 
Figure 37: Saving the result to a stereo file. 
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A tab for the newly created signal will appear in the data area (Fig. 38). 

  
Figure 38: Creating reference channel. Displaying the created signal. 

13. Perform noise reduction using Reference Noise Suppressor or Reference Noise Canceller. 
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7.5 Copying Data to the Clipboard 
Sound Cleaner II allows you to copy a selected area of the main screen or a window containing the entire signal to the clipboard and insert it 
into a report. 

To copy a screen area: 

1. Select the Service > Copy Screen Area menu option. The cursor will take shape of a +. 

2. Place the cursor on the screen and select the area you would like to copy (the area will be highlighted in a different color). 

3. Release the left mouse button. The selected area of the screen will be saved to the clipboard. 

4. In a word processor, place the cursor on the place you would like the copied screen area to be inserted. 

5. In the word processor, click Insert and the copied screen area will be inserted as a picture. 

To copy the signal window: 

1. Select the Service > Copy Window Image menu option. 

2. In a word processor, place the cursor on the place you would like the copied window image to be inserted. 

3. In the word processor, click Insert and the copied window image will be inserted as a picture. 
 

7.6 Drawing and Erasing a Signal 
The application allows you to edit shape of signal waveforms in the “Drawing/Erasing” mode. To enable this mode, click the right mouse 
button on the data area and select the Draw/Erase shortcut menu option. The cursor will take shape of a pencil. 

Press and hold the left mouse button and draw a continuous line, which will replace the previous signal waveform. 

Press and hold the right mouse button. The cursor will take shape of an eraser (red square). Move the cursor within the data area to erase a 
part of the signal. When you have finished, the line representing the signal amplitude will be shifted to zero within the fragment. 

Press Esc to disable the “Drawing/Erasing” mode. 
 

7.7 Getting Signal Properties 
To get information about the signal from the active tab within the data area, select File > File info or right-click on the data area and select 
the File info shortcut menu option. 

The Signal Properties dialog box will appear (Fig. 39), displaying the detailed file properties. 

You can copy this information to the clipboard and paste it to a text report. To do so, click the Copy button in the Signal Properties dialog. 
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Click OK to close the dialog. 

 
Figure 39: Signal Properties dialog. 

7.8 Saving Audio Files 
To save an audio file, select File > Save As... or use the Ctrl+Shift+S shortcut. 

The saving dialog box will appear. Specify the folder in which you would like to save the file, and create a new file name. Click Save. 
 

7.9 Closing Audio Files 
To close all audio files, select File > Close All. 
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8  CREATING A PROJECT 
All performed actions can be saved to a project, which will contain complete information about changes made to an audio file. 

You can also save to a project all filters applied to a file, the equalizer adjustments, comments, etc. 

A project is automatically created when the first signal alteration (editing, processing or filtering) is done. 

Each signal loaded to a project can be saved to a separate file. For more information, please refer to the 7.8 Saving Audio Files section. 
 

If any data obtained during the processing was not saved before closing the data area and/or exiting the application, the dialog box will 

appear informing about the unsaved information. 

The created project will include a .scpj file and a .scpjd folder that will contain the project information. 
 

To save a project, select the File > Save Project menu option or press the Ctrl+S shortcut. 

Specify the file path and name in the saving dialog and click Save. 
 

To open a project, select the File > Open Project... menu option. 

Select a previously saved project file and click the Open button. 

The saved project will be loaded and you can continue working with the file. 
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9  WORKING WITH A SCHEME 
9.1 Complete Scheme 
A complete scheme is the sequence of adjusted filters. You can apply it to any signal fragment or to the whole signal. 

There are two ways to display the processing sequence: filter icons (navigation scheme) (Fig. 40, pos. 1), and filter dialog boxes with settings 
(complete scheme) (Fig. 40, pos. 2). 

Each filter has its own dialog box. 

Initially, all filters are set to default settings. 

Generally the software processes left and right channels of a stereo signal separately. 

To process a signal, it is necessary to arrange the filters into sequences (schemes) depending on which channel is to be processed (left, right 
or both). 

 

To process the left or right channel of a signal: 

1. Select a filter in the list. 

2. Drag the selected filter to the processing area of the left or right channel. 
 

To use one filter for both channels: 

1. Select a filter in the list. 

2. Drag the selected filter between the upper and lower sequences of the processing area. 

Or 

1. Double-click on the selected filter in the list. 

2. The filter dialog box will appear in the processing area of the complete scheme. Right click on a filter to open a shortcut menu and 

select All Channels. 

 
The All Channels shortcut menu option is not available for the Equalizer filter. 
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To enable/disable a filter: 

1. Click the switch in the filter dialog. 

2. Left click on the filter icon in the navigation scheme. 
 

To enable/disable all the filters at the same time, select Scheme > Turn On All Filters/Turn Off All Filters. 
 

To close the filter dialog: 

1. Drag the selected filter back to the list. 

2. Open the dialog shortcut menu and select the Remove Filter option. 

 
Figure 40: Complete and navigation schemes of a processing sequence. 

  

Disabled filter icon 

Enabled filter icon 

Disabled filter box 

Enabled filter box 
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9.2 Navigation Scheme 
Navigation scheme is a visual representation of the filtering scheme using filter icons. 

Using the navigation scheme you can form a sequence of filters, but you cannot change filter settings. 

You can hide or expose this scheme. To do so, select the Navigation Scheme option in the View menu. 

Both schemes, complete and navigation, and the processing history panel can be hidden. To do so, click the  Close button above the 

navigation scheme. Only the waveform and the playback control panel will be shown in the main screen. 

To unfold the schemes and the history panel, select Navigation Scheme and/or Scheme in the View menu. 

If a long processing chain (complete scheme) was built, not all the filters will be displayed in the working area of the main screen. To display 
hidden filters in the scheme, right click a filter icon and select the Show Filter shortcut menu option. 

You also can close a filter dialog and remove a filter from the navigation scheme. To do so, right click on the filter icon in the navigation 
scheme and select the Remove Filter option. 

 

9.2.1 Saving a Scheme 
Sound Cleaner II enables the saving of a created filtration scheme as a file. A scheme includes the sequence and settings of filters. 

To save a scheme, select the Scheme > Save as... menu option. 
 

9.2.2 Opening a Scheme 
To open a previously saved processing scheme, follow these steps: 

1. Select the Scheme > Open... main menu option. 

2. Select a file with a .schm extension in the dialog and click Open. 

The previously saved complete processing scheme and the navigation scheme will appear on the screen (see Fig. 40). 
 

9.2.3 Removing a Scheme 
To remove a scheme from the working area, select the Scheme > Clear main menu option. 

If the scheme has been previously saved as a .schm file, you will be able to load it again any time. 

9.2.4 Saving a Preset 
You can save the created filtration scheme as a preset for further use using the Preset tab. 
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To save a preset: 

1. Select the Scheme > Save as Preset main menu option, or click the Save as Preset button in the Presets tab on the 

Filtration Scheme bar. 

2. In the Add Preset dialog (Fig. 41), specify the preset name and click Apply. 

You can also attach an audio file as a sample to the preset. An audio file should be loaded to the application. To add an audio file to the 
preset, select the Save preset with sound file checkbox in the Add Preset dialog. The sequence of filters, their configuration and the sound 
file will be saved into the preset. The created preset will appear in the Presets tab. 

 

If the audio file was not loaded to the application, the Save preset with sound file checkbox 
will be disabled. 

The Presets tab also contains the embedded noise reduction schemes - presets with samples of distorted audio signals. These embedded 

schemes cannot be saved, renamed or removed. 

 
Figure 41: Adding a preset. 
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9.2.5 Renaming a Preset 
To rename a preset: 

1. Select the Scheme > Rename Preset main menu option. 

2. In the dialog, select the preset you would like to rename from the drop-down list, specify another name and click Apply (Fig. 42). 
 

 
Figure 42: Renaming a preset. 

 

9.2.6 Removing a Preset 
To remove a preset from the Presets tab: 

1. Select the Scheme > Remove Preset main menu option, or select the Remove option in the preset shortcut menu. 

2. In the dialog box, select the preset you would like to remove from the drop-down list and click Apply (Fig. 43). 

 
Figure 43: Removing a preset. 
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10  FILTERING 
The noise reduction filter is a tool to process the entire signal or signal fragments. The sequence of filters is called a scheme. 

To filter a signal: 

• Select filters you would like to apply. 

• Stop playback. 

• Click Filtering on the playback control panel, in the Process menu or press Ctrl+F4. Selected filters will be applied to the signal. 

 

If you would like to apply filters to a specific part of the signal, you need to select this part of 
the recording before applying the filters. Otherwise, the entire signal will be processed. 

 

10.1 Application Filters 
Table 1. 

Filter Name Icon Description 

Cellphone Noise Filter  
 

Suppresses GSM distortions. 

STC Auto Filter 
 

Improves recording quality using only one slider. 

Clip Restorer 
 

Restores clipped signal. 

Reverb Suppressor 
 

Decreases reverberations. 

Dynamic Range Control 
 

Equalizes signal in the amplitude domain. 

Click Suppressor 
 

Performs adaptive filtering to reduce impulse noise. 

Inverse Filter 
 

Performs adaptive inverse filtering. 

DTMF Suppressor 
 

Suppresses frequencies typically associated with telephone communications 
(Duel Tone Multi-Frequency signals). 
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Filter Name Icon Description 

Reference Noise 
Suppressor  

Suppresses both non-stationary and periodical broadband noises by 
suppressing reference channel noise. 

Reference Noise 
Canceller  

Suppresses both non-stationary and periodical broadband noises by 
eliminating reference channel noise. 

Tone Suppressor 
 

Performs adaptive filtration of stationary tonal interferences and individual 
tonal impulses. 

Amplifier 
 

Increases/decreases signal level. 

Broadband Noise Filter  
Performs adaptive filtering for broadband and narrowband tonal 
interferences. 

Equalizer  Represents the spectrum graphically and changes its amplitude. 
 

10.2 STC Auto Filter 
STC Auto Filter is an automatic filter based on the Broadband Noise Filter. 

STC Auto Filter is used to extract speech signals from stationary noise backgrounds (broadband and narrowband tonal noise). 

Automatic noise filtering works well to get reliable results in a short period of time. It does not require any special noise-filtering skills or 

experience. 

This algorithm is designed to suppress broadband and periodic noises caused by electric distortions or mechanic vibrations, indoor and 

outdoor noise, communication channel or record equipment interferences. 

You may hear these noises as hums, sizzles, buzzes, rumblings, hisses or roars. 

It is nearly impossible to remove these noises with other methods, such as one-channel adaptive filtration, spectrum smoothing or the 

equalizer, as noises are spread across the entire spectrum and intersect with the speech signal. 

STC Auto Filter enables the unmasking of the speech signal at SNR values (-5 –   -10 dB). At the same time, this filter suppresses noise 

narrowband components. 

This filter has the following advantages: 

• It works within continuous speech, even with many speakers. 

• There is no need for pauses within speech. 
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10.2.1 Processing Principles 
STC Auto Filter processes the signal frame by frame. The data frame is transformed into spectrum. Then power spectral density (PSD) is 

estimated. If the frame contains a useful signal pause (noise signal fragment), then current PSD is used to accumulate averaged PSD of noise. 

Current PSD is compared with accumulated noise PSD at each frequency. Signal spectrum weakens at the frequencies where current frame 

PSD is proportionate with noise PSD (as at these frequencies useful signal has no components or they are too weak for an ear to detect them). 

Signal spectral components are saved at those frequencies, where current PSD is larger than noise PSD. This procedure is called spectrum 

subtraction. 

After that a filtered frame spectrum is transformed back to the time zone. 

This processing algorithm can be compared with dynamic equalizer, which changes its characteristics at each frame several tens of times per 

second. 

Using such equalizer operation for a large frame, it may result with echo. Processing parameters are used to control equalizer operation mode 

(quantity of spectral bands, noise statistics acquisition interval, etc.). 
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10.2.2 STC Auto Filter Controls 

 
Figure 44: STC Auto Filter. 

The filter controls are: 

1 Enable/Disable filter. 

2 Suppression Depth slider control (1–40). 

3 Suppression Depth indicator. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

The main parameter of Auto Filter is Suppression Depth. 

This parameter can be configured within the range of 1–40 dB. It controls the suppression level of the noise component. 

For better perception, the optimum suppression depth should be 12–18 dB. 

“Musical noise” may appear at large values, as it has an uneven sound that complicates signal perception. 

Large values of suppression depth can be used to suppress strong stationary tone noises. 
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10.3 Clip Restorer 
Clip Restorer is used for removing clipping effects, such as strong bursts, “metallic” sounds and excessive rising of high frequency 

components (sizzle). 

Clipping is a form of distortion that limits a signal once it exceeds a threshold. 

On a waveform, clipping usually looks like signal amplitude limitation (Fig. 45). 

 
Figure 45: Clipped signal. 
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10.3.1 Processing Principles 
Clip Restorer is based on a controlled cutoff of high frequency signal components which are the reason for the “metallic” sound. 

To remove loud high frequency sizzle sounds, you can also use the LP Filter. It suppresses high frequency signal components with 

frequencies above 3 kHz. 

Figure 45 shows the same signal as in Figure 46, after it has been restored with Clip Restorer. 

 
Figure 46: Restored signal. 

Clip Restorer reduces signal amplitude, especially with large suppression depth. 

In such cases, it is recommended to additionally amplify the signal. 
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10.3.2 Clip Restorer Controls 

 
Figure 47: Clip Restorer. 

The filter controls are: 

1 Enable/Disable filter. 

2 Suppression Depth slider control (1–100). 

3 Suppression Depth indicator. 

4 Enable/Disable LP Filter. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

10.3.3 Filter Functioning 
To restore a clipped signal: 

1. Enable the filter. 

2. Adjust the slider. 

3. If the sound is too weak after using Clip Restorer, enable the Amplifier filter. 

4. If necessary, enable the LP Filter. 
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10.4 Reverb Suppressor 
10.4.1 Processing Principles 
Reverb Suppressor is used to decrease reverberations, i.e. non-stationary noise, generated by a speech signal.  
This filter is similar to the Broadband Noise Filter, but uses a different method of estimating the noise spectrum.  

10.4.2 Reverb Suppressor Controls 

 
Figure 48: Reverb Suppressor. 

The filter controls are: 

1 Enable/Disable filter. 

2 Suppression Depth slider control (1–40). 

3 Suppression Depth indicator. 

4 Adaptation Time slider control (0.2–2). 

5 Adaptation Time indicator. 

6 Enable/Disable Whitening mode. 

7 Enable/Disable Subtracted Signal mode. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

The main, and most important, parameters of the filter are Suppression Depth and Adaptation Time. 

Suppression Depth can be configured within the range of 1–40 dB. It controls the suppression level of the noise components. 

For better perception, the optimum suppression depth should be 12–18 dB. 

“Musical noise” may appear at large values; it has an uneven sound that complicates signal perception. 

Large values of suppression depth can be used to suppress strong stationary tone noises. 
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Adaptation Time enables setting adjustment time, i.e. the time the filter needs to adjust to the variations of the noise spectrum. Generally, it 

is recommended to set values around 0.5 s. You should also adjust the time constant within 1.0–2.0 s or 0.2–0.5 s intervals according to the 

type of reverberation suppression (soft/deep). 

Increasing suppression depth and decreasing adaptation time significantly reduces noise, it can impair the quality of the speech signal by 

decreasing the level of useful signal. 

You can control the level of speech suppression by listening to the subtracted signal. To do so, press the Subtracted Signal button. 

Whitening is an additional filtration mode. It suppresses noise at frequencies where its level is very high. This mode whitens the spectrum of 

remaining noise, which makes the filtered signal more audible. 
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10.5 Dynamic Range Control 
10.5.1 Processing Principles 
Dynamic Range Control is used to improve the intelligibility of speech signals if there are significant signal level differences, booming noises, 

long pulses or indoor noises. 

Dynamic processing algorithms improve the audio signal quality and suppress strong impulses and clicks, unmasking the signal. The filter 

aligns the signal level in different areas that makes the signal more audible. 

Dynamic processing algorithms perform the following functions: 

• Equalize speech level. 
• Reduce signal to specified level. 
• Suppress impulse and bump noises (hearing protection). 
• Perform gain control of the recording device. 
• Expand the dynamic range of a signal. 
• Suppress signal in pauses. 

10.5.2 Filter Controls 

 
Figure 49: Dynamic Range Control. 

The filter controls are: 

1 Enable/Disable filter. 

2 Output Level input box. 

3 Strong Signal checkboxes. 

4 Weak Signal checkboxes. 
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The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

Specify the average value of signal amplitude in the Output Level input box. 

Used to distinguish between strong and weak signals, it reduces the volume of strong sounds and amplifies weak sounds by narrowing or 

“compressing” an audio signal dynamic range. 

When reducing the amplitude of the loud sounds, the dynamic filter will reduce the loud sounds by an amount equal or less than the user 

setting. 

When amplifying the amplitude of the low level sounds, the dynamic filter will amplify the low level sounds by an amount equal or less than 

the user setting. 

Maximum gain to a weak signal is 26 dB. 

Radio-buttons in the middle of the dialog enable adjusting dynamic processing modes for strong and weak signals separately. Strong 

signals may remain at their initial level or can be weakened, which is usually done to bring loud speech down to threshold value or 

eliminate strong and long (more than 20 ms) impulses or knocks. 

You can also amplify weak signals to balance the speech level of two speakers, leave them unchanged (remain) or weaken them, which may 

be useful for suppressing noise in pauses between loud speech fragments. 
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10.6 Click Suppressor 
Click Suppressor is used to automatically restore speech or music signals distorted and masked by various impulse distortions, such as 

clicks, radio distortions, knocks, etc. 

Click Suppressor improves the quality of audio signals, suppresses strong signal impulses and clicks, unmasking useful audio signal and 

increasing its intelligibility and quality. 

10.6.1 Processing Principles 
During the impulse filtration, Sound Cleaner II substitutes impulses with smoothened and weakened interpolated signals. If the application 

does not detect an impulse, it leaves the fragment unchanged. It also does not suppress tonal or broadband noises. Impulse detection is 

based upon the information the application has about differences between useful signal and noise. Thus, setting filtration parameters 

correctly is crucial for effective processing. 

10.6.2 Click Suppressor Controls 

 
Figure 50: Clip Suppressor. 

The filter controls are: 

1 Enable/Disable filter. 

2 Suppression Level slider control (1–10). 

3 Suppression Level indicator. 

4 Pulse length slider control (1–10). 

5 Pulse length indicator. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 
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To adjust impulse filtration: 

1. Suppression Level is used to detect and locate the impulses based upon their energy. The default value is 6. Increasing the 

suppression level will make the application locate weaker impulses. Setting low suppression level values will leave the weak impulses 

intact. If the value you have set is too high, then sudden changes of useful signal level will be considered impulse interferences and 

removed. 

2. Pulse length slider controls the detection and localization of impulses according to their duration. By decreasing this value, you will 

enable the application to detect short and weak impulses, however, this will impair the localization of longer impulses. 
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10.7 Inverse Filter 
10.7.1 Processing Principles 
Inverse Filter effectively suppresses strong, stationary periodic noises caused by electrical interference or mechanical vibrations, recovering 

the speech signal and equalizing the signal frequency response. 

The algorithm of this filter is based on spectral equalizing (the reduction of the average spectrum of a signal to a flat spectrum of white noise). 

Formant and tonal speech structure of separate sounds are preserved. 

It amplifies the weaker signal components and suppresses the stronger ones at the same time. By reducing the spectrum, the speech signal 

increases and becomes more intelligible. 

Broadband noise, however, usually becomes stronger, making signal less audible. Try to reach a balance between noise and voice 

intelligibility. 

10.7.2 Inverse Filter Controls 

 
Figure 51: Inverse Filter. 

The filter controls are: 

1 Enable/Disable filter. 

2 Suppress Spectrum Components slider control (1–24). 

3 Suppress Spectrum Components indicator. 

4  Amplify Spectrum Components slider control (0–50). 

5 Amplify Spectrum Components indicator. 

6 Enable/Disable Speech Equalizer mode. 
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The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

To adjust Inverse Filter: 

1. The Suppress Spectrum Components parameter attenuates uneven noise peaks towards a flatter curve. The suggested range is 12 – 

24 dB. 

2. The Amplify Spectrum Components parameter enables the adjusting of ultimate amplification of weak spectrum components for 

every frequency. This parameter is used to control the equalization level of a spectrum by amplifying weak components (usually on 

high frequencies). A threshold is needed to avoid amplifying the broadband noise on high frequencies. 12–24 dB values are 

recommended. 

The Speech Equalizer uses a voice spectrum curve. This voice curve can make listening easier than the flat curve. 
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10.8 DTMF Suppressor 
DTMF Suppressor is used to suppress two-frequency phone dialing signals that mask the useful signal. 

DTMF signals are the signals used for voice-frequency dialing. On a waveform, DTMF signals are displayed as a sequence of short (approx. 

0.2 s), rectangular, dual-frequency impulses. There are two types of frequency values: low-frequency (LF) and high-frequency (HF). There are 

four fixed frequencies within each group: 

• LF: 697 Hz, 770 Hz, 852 Hz, 941 Hz. 

• HF: 1209 Hz, 1336 Hz, 1477 Hz, 1633 Hz. 

DTMF signal is generated by a combination of two frequencies: one from the first group, and one from the second. 

 

 
Figure 52: Typical view of a speech signal distorted by DTMF noise. Waveform (above) and spectrogram (below). 
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10.8.1 Processing Principles 
DTMF Suppressor automatically detects DTMF distortions, defines the frequencies and applies the filters designed to suppress them. 

When the filter is enabled, short impulses may appear at the beginning and end of the DTMF noise. On the waveform, the impulses are 

displayed as waveform swings. They sound like periodically recurring clicks and can be removed with Click Suppressor. 

10.8.2 DTMF Suppressor Controls 

 
Figure 53: DTMF Suppressor. 

The filter controls are: 

1 Enable/Disable filter. 

2 Suppression Depth slider control (1–10). 

3 Suppression Depth indicator. 

4 Enable/Disable Click Suppressor. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

10.8.3 Filter Functioning 
To suppress DTMF signals: 

1. Enable filter. 

2. Adjust the slider. 

3. If necessary, enable Click Suppressor.  
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10.9 Cellphone Noise Filter 
Cellphone Noise Filter is used to suppress cellphone distortions that affect useful signal during the process of audio recording. 

GSM distortion occurs in GSM networks. It is a sequence of short consecutive impulses, usually of high amplitude, with a frequency of about 

F0 = 217 Hz. The frequency can vary slightly. GSM interference sounds like a rough pulsating buzzing. 

 
Figure 54: Typical waveform of GSM distortion. 
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10.9.1 Processing Principles 
Cellphone Noise Filter automatically detects GSM noise and enables filters to suppress the central frequency F0 (approximately 217 Hz) and 

its harmonics. There can not only be multiple harmonics (i.e. F0 × 2; F0 × 3, etc.), but also harmonics located between the main ones (i.e. the 

step between harmonics can be F0and F0/2). This step should be set manually. To remove short clicks, use Click Suppressor. 

AutoDetect performs automatic GSM distortion detection in a processed signal and enables the suppressor. 

If AutoDetect is off, the suppressor is constantly on. 

In some cases, AutoDetect will fail to detect distortion, for example, when it is masked by a strong speech signal. Some noise will occur at the 

same frequencies created by the cell phone; therefore the filter will also suppress the desired audio. 

To make AutoDetect more efficient: 

• Turn AutoDetect on if the distortion is strong and the useful signal is weak. 

• Enable both modes if the distortion is weak and the useful signal is strong. 

When the filter is enabled, short impulses may appear at the beginning and end of the DTMF noise. On the waveform, the impulses are 

displayed as waveform swings. They sound like periodically recurring clicks and can be removed with Click Suppressor. 
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10.9.2 Cellphone Noise Filter Controls 

  
Figure 55: Cellphone Noise Filter. 

The filter controls are: 

1 Enable/Disable filter.  

2 Initial cutoff frequency. 

3 Maximum frequency, where harmonics can be found in the input box. 

4 Frequency step input box. 

5 Suppression Depth slider control (1–10). 

6 Suppression Depth indicator. 

7 Enable/Disable AutoDetect. 

8 Enable/Disable Click Suppressor. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 
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10.9.3 Filter Functioning 
To suppress GSM interferences: 

1. Enable the filter. 

2. Specify the initial cutoff frequency. Generally, this value is 217 Hz. 

To make sure the initial cutoff frequency is specified correctly, use the Spectrum Analyzer in Equalizer before applying Cellphone Noise 

Filter. 

3. Specify the maximum frequency. If this value is unknown, use the Spectrum Analyzer or specify a value half as large as the sampling 

frequency. 

4. Specify the step. Generally, this value is 217 Hz. 

To make sure the step is specified correctly, use the Spectrum Analyzer in Equalizer before applying Cellphone Noise Filter. 

5. Adjust the suppression depth. 

6. Enable AutoDetect and Click Suppressor. 

7. Perform the filtration and play back the signal. 

8. If the result is not satisfying, halve the step value. 

9. Adjust the maximum frequency. 

10. If necessary, adjust the parameters. 

11. Apply the filter with AutoDetect and Click Suppressor disabled. 
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10.10 Reference Noise Canceller  
10.10.1 Processing Principles 
Reference Noise Canceller is designed to suppress both non-stationary broadband (background speech, radio, indoor noise) and periodic 

noises (vibrations, power-line distortions, etc.). When extracting the useful speech signal from the main channel, the application uses 

additional information about distortion properties provided in the reference channel. Reference Noise Canceller can preserve a weak 

speech signal with a loud background noise only if the noise signals in the main and reference channels are correlated. 

Stereo filtering does have a number of limitations. Its efficiency is reduced under the following conditions: 

• If there is a large distance between the main channel microphone and the speaker (reverberation). 

• If the distortion signal is taken from the electric output of the audio device (nonlinear sound distortions in the acoustic speaker). 
 

10.10.2 Reference Noise Canceller Controls 

 
Figure 56: Reference Noise Canceller. 

The filter controls are: 

1 Enable/Disable filter. 

2 Smoothing slider control (0–10). 

3 Smoothing indicator. 

4 Delay slider control (-10–20). 

5 Delay indicator. 
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6 Enable/Disable Main Channel Left/Right. 

7 Enable/Disable Subtracted Signal. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

The Smoothing parameter sets the inversely proportional to the synchronization speed distortions in main and reference channels. 

The Delay parameter displays the time it takes for the distortion to reach the main channel microphone (if the reference channel signal is 

reordered directly at the distortion source). 

The Main Channel (Left/Right) radio buttons are used to select the channel for processing, as signals can be recorded randomly. 

The Subtracted Signal button is used to select the main channel; the subtracted signal should contain the useful signal. 

The Residual Signal is the difference between the main channel signals before and after processing. It contains noise and useful speech 

signal fragments and enables adjusting the sound processing mode (the smoothing intensity) to minimize speech signal distortions in the 

main channel. 
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10.11 Reference Noise Suppressor 
10.11.1 Processing Principles 
Reference Noise Suppressor is designed to suppress both non-stationary broadband (background speech, radio, indoor noise) and 

periodical noises (vibrations, power-line distortions, etc.). When extracting the useful speech signal (in the main channel), additional 

information about distortion properties are needed. Reference Noise Suppressor can reduce distortions even if the noise signal in the main 

and reference channels have a weak correlation. 

Stereo filtering has a number of limitations. Its efficiency is reduced under the following conditions: 

• If there is a large distance between the main channel microphone and the speaker (reverberation). 

• If there is strong interference, weak components of the speech signal may be suppressed. 

10.11.2 Reference Noise Suppressor Controls 

 
Figure 57: Reference Noise Suppressor. 
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The filter controls are: 

1 Enable/Disable filter. 

2 Suppression Depth slider control (1–40). 

3 Suppression Depth indicator. 

4 Smoothing slider control (1–10). 

5 Smoothing indicator. 

6 Delay slider control (-10–20). 

7 Delay indicator. 

8 Enable/Disable Main Channel Left/Right. 

9 Enable/Disable Subtracted Signal. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

The Suppression Depth parameter enables setting the depth of the interference signal suppression in the main channel. 

The Smoothing parameter sets the inversely proportional to the synchronization speed distortions in main and reference channels. 

The Delay parameter displays the time it takes for the distortion to reach the main channel microphone (if the reference channel signal is 

positioned toward the distortion source). 

The Main Channel (Left/Right) radio buttons are used to select the channel for processing, as signals can be recorded randomly. 

The Subtracted Signal button is used to select the main channel; the subtracted signal should contain the useful signal. 

The Residual Signal is the difference between the main channel signals before and after processing. It contains noise and useful speech 

signal fragments and enables adjusting the sound processing mode (the smoothing intensity) to minimize speech signal distortions in the 

main channel. 
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10.12 Tone Suppressor 
Tone Suppressor is used to suppress stationary tonal interferences and individual tonal impulses. This filter is effective at suppressing 

narrow-band interference and regular noise. When the adaptation parameters are not set correctly, Tone Suppressor will leave the useful 

speech signal unaltered.  

Tone Suppressor searches for strong peaks in the signal spectrum and suppresses them. 
 

10.12.1 Processing Principles 
Tone Suppressor is used to remove narrow-band stationary and non-stationary interferences (vibrations, network interferences, household 

appliance noises, slow music, traffic sounds, sirens, etc.) and tonal impulses (phone impulses, tonal music, etc.) from the signal. Suppression of 

tonal noise in the spectral area enables the unmasking of speech signals and the suppression of tonal interference by 20–40 dB. 

Certain noises do not crucially affect the useful signal. This method of noise cancellation suppresses only narrow-band components, leaving 

the rest of the signal spectrum unchanged without affecting the useful signal. 

The main parameters of adaptive compensation that determine the level of noise suppression are Frame size and the filter Adaptation Time. 

Increasing the coefficient leads to the suppression of distortion spectral peaks and at the same time decreases filter performance and its 

ability to adjust to rapidly changing interference. The greater the time coefficient, the greater the attenuation of the sound peaks. The filter 

will also take longer to adjust to rapidly changing sounds when the time coefficient is increased. Delay time is used to adjust the filter to 

interferences that change rapidly or slowly. 
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10.12.2 Tone Suppressor Controls 

 
Figure 58: Tone Suppressor. 

The filter controls are: 

1   Filter ON/OFF switch. 

2, 3   Mode and frame size drop-down lists. 

4    Adaptation Time slider control (0.2–2). 

5   Adaptation Time indicator. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 
 

The main parameter of Tone Suppressor is Frame size. It determines the number of spectral bands and the size of the processed data unit. 

The higher the value, the greater the number of spectral peaks that can be suppressed. Therefore, it is recommended to increase the frame 

size to compensate for the interference of noises, such as hum and buzz. On the other hand, setting too large a frame size parameter can 

cause echo. In case of a small number of frequencies of tonal interference, adjust the frame size to within 256–512 samples. 

Adaptation Time specifies adjustment time, i.e. time the filter needs to adjust to the distortion spectrum differences. Generally, the 

recommended value is around 1 s. 

For rapidly changing noise, the adaptation time should be decreased; for slowly changing noise, this parameter should be increased. 

When reducing adaptation time, the quality of the processed speech signal may become worse, as speech signals can contain rapidly 

changing tonal components.  
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10.13 Amplifier 
The Amplifier filter is used to increase or decrease the signal level within the range of 20 dB. 

10.13.1 Amplifier Controls 

 
Figure 59: Amplifier. 

The filter controls are: 

1 Enable/Disable filter. 

2 Gain control display. 

3 Gain slider control (-20–20). 

4 Gain indicator. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

The Gain control is adjusted by the slider; the current value is displayed in the gain indicator box. If you would like to reduce the 
amplification level, move the slider control all the way to the left (when the value is 0dB the signal is not amplified). 

During processing, the signal level may reduce due to frequency corrections and noise reduction. These actions weaken some useful signal 

components that can be lost during further processing. One option to prevent this is to amplify an audio signal during the process of 

correction and noise reduction. 

If the specified gain value is too high, the red check indicator located on the gain control display will alert you. 
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10.14 Broadband Noise Filter 
Broadband Noise Filter is used to extract speech signals from stationary interference background (broadband and narrowband tonal 

interferences). 

This algorithm is designed to suppress broadband and periodic noises caused by electrical distortions or mechanic vibrations, indoor and 

outdoor noise, communication channel or record equipment interferences. 

You may hear these noises as hums, sizzles, buzzes, rumblings, hisses or roars. 

It is nearly impossible to remove such noises with other methods, such as one-channel adaptive filtration, spectrum smoothing or with the 

equalizer, as they are spread across the whole spectrum and intersect with the speech signal. 

Broadband Noise Filter enables unmasking the speech signal at SNR values (-5 – -10 dB). At the same time, the filter suppresses noise 

narrowband components. 

This filter has the following advantages: 

• It works within continuous speech, even with many speakers. 

• There is no need for pauses in speech. 
 

10.14.1 Processing Principles 
Broadband Noise Filter processes the signal frame by frame. The data frame is transformed into a spectrum, after which, the power spectral 

density (PSD) is estimated. If the frame contains a useful signal pause (noise signal fragment), then the current PSD is used to accumulate the 

averaged PSD of the noise. The current PSD is compared with the accumulated noise PSD at each frequency. The signal spectrum weakens at 

the frequencies where the current frame PSD is proportionate with the noise PSD, as at these frequencies the useful signal has no 

components or they are too weak to be detected. Signal spectral components are saved at those frequencies where the current PSD is larger 

than the noise PSD, in a procedure called spectrum subtraction. 

A filtered frame spectrum is then transformed back to the time zone. 

This processing algorithm is similar to the dynamic equalizer operation, which changes its characteristics at each frame several tens of times 

per second. 

Applying this option for a large frame can cause an echo. Processing parameters are used to control the equalizer operation mode (quantity 

of spectral bands, noise statistics acquisition interval, etc.).  



93 
FILTERING Sound Cleaner II 

  User Guide 
 

 

10.14.2 Broadband Noise Filter Controls 

 
Figure 60: Broadband Noise Filter. 

The filter controls are as follows: 

1 Enable/Disable filter. 

2 Suppression Depth slider control (1–40). 

3 Suppression Depth indicator. 

4 Adaptation Time slider control (0.2–2). 

5 Adaptation Time indicator. 

6 Enable/Disable Whitening mode. 

7 Enable/Disable Subtracted Signal mode. 

The RESET button in the bottom left corner of the dialog restores the filter to default settings. 

The primary parameters of the filter are Suppression Depth and Adaptation Time. 

Suppression Depth can be configured within the range of 1–40 dB. It adjusts the maximum suppression of noise spectral components. 

For better perception, the optimum suppression depth should be 12–18 dB. 

“Musical noise” may appear at large values, as it has an uneven sound that makes signal less audible. 

Large values of suppression depth can be used to suppress strong, stationary tone noises. 

Adaptation Time specifies adjustment time, i.e. time the filter needs to adjust to the distortion spectrum differences. Generally, the 

recommended value is around 1-2 s; for non-stationary noises the recommended values are 0.2–0.5 s. 

Adaptation Time sets the constant of adaptation time to the noise level changes of. Actual time of complete filter adjustment can be either 

more or less than a specified value. 
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Increasing suppression depth and decreasing adaptation time significantly decreases noise, but it can affect speech signal quality and reduce 

the level of the useful signal. 

You can control the speech suppression level by listening to the subtracted signal. To do so, enable the Subtracted Signal mode. 

Whitening is an additional filtration mode in which high frequency noises are suppressed. This mode whitens the spectrum of remaining 

noise, making the filtered signal more audible. 
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10.15 Equalizer 
Equalizer displays the signal spectrum and enables the correction of signal amplitude. Equalizer works in automatic or semi-automatic 

modes. It is used to suppress any stationary components of a signal, regardless of their frequency and location. It also weakens or strengthens 

the amplitude of a certain spectral band. This filter is especially efficient for processing audio recordings distorted with strong stationary 

noises such as power-line noise, mechanical and engine noises, etc. 

There are two Equalizer dialogs in the application: the Spectrum Analyzer dialog (Fig. 61) and the Multiband Equalizer dialog (Fig. 62). 

 
Figure 61: Spectrum Analyzer. 

In Filtration Scheme, the equalizer dialog is displayed without sliders as a Spectrum Analyzer. 

To perform an operation with the spectrum, open the Multiband Equalizer dialog by double clicking on the Spectrum Analyzer dialog. 
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10.15.1 Multiband Graphic Equalizer Controls 
The Multiband Equalizer dialog (Fig. 62) consists of the following elements: 

1 Header and toolbar. 

2 Spectrum analyzer setting bar. 

3 Spectrum analyzer area. 

4 Horizontal scroll bar. 

5 Graphic equalizer. 

6 Sling indicator and Additional FC Adjustment slider controls. 

Specify the type of spectrum in the input box located on the spectrum analyzer settings bar. 

Instantaneous: is a spectrum of a short signal fragment. Duration of this fragment is defined by the length of the FFT window. The displayed 

spectrum corresponds to the file being played. 

Accumulated: averages the input signal spectrum. 
 

 
Accumulated spectrum can only be applied to an input signal. 

 

You can also select the amplitude displaying scale. 

Logarithmic: enables logarithmic (decibel) displaying of the amplitude scale. 

Linear: enables linear displaying of the amplitude scale. 

Select the equalizer band number in the Bands drop-down list. The more bands are selected, the more accurate the spectrum will be 

displayed. The fast Fourier transformation (FFT) window size is 4 times larger than the bands number, so 1 band corresponds to 4 FFT points. 

Spectrum analyzer window displays current signal (spectrum) (blue color) and filter (green color) with horizontal belt indicator. 

Vertical marks (two white lines in the spectrum analyzer area) limit the area for filter application. You can change their location during signal 

processing. 

The RESET button in the bottom left corner of the dialog restores the filter default settings. 

Minimize, maximize and close buttons are located in the upper right corner of the dialog: 
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To perform spectrum alterations, use the vertical sliders in the equalizer area (sliders for adjusting filter bands). If you click above or below the 

slider, the value will change by 18, so to move the slider from 0 to -72, you need to click 4 times. 

You can also move all sliders together. To do so, enable the Sling mode (for more information, please refer to the Sling Mode section). 

 
Figure 62: Multiband Equalizer. 
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10.15.2 Equalizer Toolbar 
Table 2. Equalizer Toolbar Controls 

Button Name Action 

 
Horizontal auto zoom Displays the entire signal along the horizontal axis. 

 
Vertical auto zoom Displays the entire signal along the vertical axis. 

 
Input signal spectrum Displays input signal spectrum. 

 
Output signal spectrum Displays output signal spectrum. 

 
Contrasting Aligns the filter’s negative peaks. 

 
Sling Connects several sliders for simultaneous control. 

 
High-pass filter 

Automatically adjusts the sliders to skip frequencies below the right vertical slider in the 

Spectrum Analyzer window. 

 
Low-pass filter 

Automatically adjusts the sliders to skip frequencies above the left vertical slider in the 

Spectrum Analyzer window. 

 
Inverse filter Automatically performs an inversion of the signal spectrum. 

 
Harmonic filter Automatically detects and suppresses stationary harmonics. 

 
Spectrum saving filter Automatically creates a filter with a frequency response equal to that of the input signal. 

 
Accumulate average spectrum  Accumulates spectrum, displaying the average spectrum of the entire signal. 
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Sound Cleaner II enables the saving of equalizer settings generated while creating a report (for more information, please refer to the 

12 CREATING A REPORT section). Equalizer settings are not displayed in the text report, but are saved as a separate file. The report contains 

only the name of said file. 

To save the current profile, click  Save settings as a preset (located in the equalizer toolbar). 

In the dialog, specify the preset name and click OK. 

The current profile will be displayed in the Preset bar (located in the equalizer toolbar) (Fig. 62). 

To download a previously saved profile: 

1. In the Preset drop-down list, select From file…. 

2. In the dialog, select a file with extension .eqp and click Open. 

To delete the profile, click  Delete preset. 
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10.15.3 Zooming and Scrolling 
Sound Cleaner II enables changing the borders of the spectrum displayed in the window. 

Place the cursor on the vertical (Fig. 63, pos. 1) or horizontal (Fig. 63, pos. 2) scale and rotate the mouse wheel. 

 

To display the whole spectrum in the window, use a scroll box on the horizontal scroll bar (Fig. 63, pos. 4). 

In this mode, both  and  buttons (Fig. 63, pos. 3 and 5) will be active. 

 
Figure 63: Spectrum area. 

  

1 

3 
2 
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10.15.4 Adjusting Filter FC 
There are 32 frequency response adjustment sliders in the equalizer window. 

To adjust Filter FC, use the sliders or specify the exact degree of amplification/attenuation of the signal in the indicators. 

The Bands per slider field displays the actual number of bands for one slider. The graphic equalizer has 4096 bands. The number of bands 

per slider depends on the selected FFT window size and on the scale. 

There is digital indicator (in dB) above each slider, used to display the amplification and attenuation degree of the signal in the band. The 

highest and lowest possible values (+20/-72 dB), which correspond to the extreme slider positions, are to the left of the sliders. 
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10.15.5 Sling Mode 
The Sling mode allows you to adjust several sliders simultaneously. In this mode, it is much easier to change the Filter FC smoothly. 

To connect the sliders into one group, click the Sling button in the equalizer toolbar. 

The belt indicator, located below the sliders, is active only when Sling mode is on, and is used to adjust the left and right borders of the group. 

The selected group will be marked with a blue indicator in the bar. 

To control the connected sliders, click the left mouse button on one of the sliders and drag the chain down. 

Dragging one slider will set all sliders to the same average value. 

Dragging one slider with Shift pressed will set all sliders to the same value. 

Dragging one slider with Ctrl pressed will set the filter to simulate a graphic equalizer with a step effect. 

The value of the dragged slider is considered a limit (minimum or maximum) for the last band. Once the slider is released, it will change the 

value, displaying the averaged value of the corresponding bands. 

Only sliders (not filter bands) may be grouped and bound together. If you zoom in or out, the sliders you have previously included in a group 

will control other signal bands. 
 

10.15.6 Additional FC Adjustment 
The Q1 and Q2 sliders, located at the very bottom of the screen, provide additional filter FC adjustment. This extra adjustment makes speech 

sound more natural audible. 

Q1 adjusts FC convexity within the 100–800 Hz frequency band. Once the marks have appeared, Q1 will affect the area to the right of the left 

mark, and not to the area of LF (100–800). 

Q2 changes FC increase/decrease for every 1000 Hz starting from 1000 Hz. Both sliders work within the -18/+18 dB range with current value 

indicated to the right of it. 
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11  SIGNAL PROCESSING 
To process the signal, use the Processing menu options. 

To apply the changes and start signal processing, click Apply. 

To close the dialog without saving changes, click Cancel. 

 

Select the data processing area. Generally, the entire signal is processed, but if a signal 
fragment is selected, filtering will be applied only to the selected fragment. 

 

11.1 Normalization 
Normalization is used to adjust the maximum level of amplitude for entire signal or for signal fragments. By normalizing audio signals to 

32,767 samples or 0 dB, you can reach the highest amplitude level. The application applies peak normalization, at which the signal level rises 

to the maximum level for digital audio without distortions. There is no need in clipping with this method. However, if the audio file has at 

least one peak standing out against the entire recording background, the audio signal may remain fairly low when normalizing. In this case, it 

is recommended that you normalize the necessary fragments instead of the entire signal. 

 
Figure 64: Amplitude Normalization. 

 

Normalization can be used in the following cases: 
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• Before playback to increase the volume. 

• After filtering to compensate signal amplitude reduction caused by noise reduction filters. 

Normalization by Amplitude is used to adjust the symmetrical normalization above and below the center of a sound wave. It can be applied 

in most cases. 

Normalization in Interval is used to adjust the normalization of the area above or below the center of a sound wave. 

Specify the value in samples or decibels using the slider, or enter the value manually in the Samples field. 
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11.2 Clipping 
Clipping is used to limit the output level of the overall sound and will attenuate fast, loud sounds. 

 

This signal processing method reduces the psychoacoustic effect of temporary masking. 

Clipping by Amplitude is used to clip the waveform symmetrically above and below the center of a sound wave. It can be applied in most 

cases. 

Clipping in Interval is used to adjust clipping for the area above or below the center of a sound wave. 

Specify the value in samples or decibels with the slider, or enter the value manually in the Samples field. 

 
Figure 65: Amplitude Clipping. 
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11.3 Resampling 
Resampling is used to change the sampling rate of a source signal. 

Spectral components of a speech signal that affect speech intelligibility are approximately below 5 kHz. 

To increase speech intelligibility, you need to lower the sampling rate down to 11,025 Hz. It will partially reduce high-frequency noises and 

simplify the task of spectrum correction using the equalizer. 

Divide to Integer is used to lower the sampling rate to the nearest multiple of the current frequency. 

Set to Arbitrary is used to specify the necessary signal sampling rate in the range from 4000 to 192,000 Hz. 

Select a random sampling rate from the drop-down list, or enter the value manually in the New Sample Rate field. 

Band Width is used to display the actual frequency band after resampling. 

 

 

The outer limits of the signal range will be from 0 Hz to the center of the sample rate of the old 
signal. In the conversion, the unused signals are attenuated by 72 dB or more. The Band Width 
displays the upper frequency of the new signal. 

 

 
Figure 66: Resampling. 
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11.4 Tempo Correction 
Tempo correction is used to slow down or accelerate the sound without changing the timbre. 

This method should be used for relatively low-frequency speech when compared to the sampling rate. 

It is not recommended to slow down a high-singing, female voice recorded with the sampling rate of 8 kHz. 

Use this method at the very end of the filtering process, just prior to playback. 

 
The white noise slowed down 3 times turns to a tonal one, and a voice becomes “drunken”. 

 

Value is used to adjust speed value between 0.33 (slowdown) to 3 (acceleration). You can set the value using the slider or by entering it 

manually in the Value field. 

The value will have relative accuracy of 10-14 (if the Tempo Accuracy type is selected). 

Signal Quality is used to preserve the high quality of the output signal; some fragments of speech will not be sped up or slowed down. 

Tempo Accuracy is used to preserve the specified value of tempo correction factor, even at the expense of quality. 

Pitch Period is the expected length of pitch in seconds. When increasing this parameter, the output signal envelope curve takes the shape of 

a sawtooth and specific overtones occur. Decreasing this parameter may cause clicks. 

 
Figure 67: Tempo Correction. 
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12  CREATING A REPORT 
To analyze the signal processing results, you can create a report that will be based on the data obtained during the session. 

The report will contain information about an audio file, user, applied filters and their settings, company details, report creation time, images of 

source and processed signal with their spectrums, text comments, etc. 

Reports are saved in HTML format. To open an HTML report, use any browser (Mozilla Firefox, Internet Explorer, etc.). You can also open a 

report using any text editor (MS Word, OpenOffice). To do so, right-click the report and select Open with. 

To create a report, click File > Create report or press Ctrl+W on the keyboard. 

In the creating report dialog, specify the data (company details, report creation time, etc.) and click Create (Fig. 68). 

In the saving dialog, specify a name and access path to the report and click Save. 

By default, reports are saved to the folder with the following path: C:\Program Files\Speech Technology Center\SoundCleaner II. 

 
Figure 68: Creating a report. 
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13  TEXT TRANSCRIPTION 
Transcriber is a part of Sound Cleaner II used to create a text transcription of a recording. 

To open the Transcriber module, click Service > Transcriber. 

Enter the text of a simultaneously playing recording in the input box of Transcriber (Fig. 69, pos. 2). The application will start to compare text 

and sound, creating a transcript of the audio file. During playback, the application can highlight the text entered by the user. To do so, enable 

this option before opening Transcriber (for more information, please refer to the 15 CONFIGURING THE APPLICATION section). 

Transcriber bar consists of the following elements: 

1 Toolbar. 

2 Text input box. 

  
Figure 69. Transcriber. 

To close the Transcriber module: 

1. In the right corner of the toolbar, click . 

2. In the Service menu, untick the Transcriber check box. 

The Transcriber toolbar (Fig. 69, pos. 1) contains controls to select the font face, font size, text format and alignment. 

You can see the screen tips by placing the cursor on any of the toolbar elements. 

 

When the Transcriber module is on, the Space key cannot be used to control playback. In this 
case, use the Ctrl+Space shortcut. 
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Table 3. Text Formatting Elements 

Element Designation Allocation 

 Font. Font Size Changes the font and font size. 

 Bold Applies the bold style to selected text. 

 Italic Applies the italic style to selected text. 

 Underlined Underlines selected text. 

 Left Aligns text to the left. 

 Center Centers a text. 

 Right Aligns a text to the right. 

 Justify Justifies the selected text. 
 

Toolbar editing options, Transcriber context menu options, and application shortcuts (Fig. 69, pos. 1, Fig. 70) are used to perform the 

following editing functions: 

Undo: undoes the last performed action. 

Redo: redoes the undone action. 

Cut: cuts selected area out of the text. 

Copy: copies selected area of the text. 

Paste: pastes selected text to a specified area. 

Delete: deletes selected area of the text. 

Select All: selects all the text in the string. 
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Figure 70: Transcriber context menu. 
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14  PROCESSING HISTORY 
The History tab of Filtration Scheme displays all actions performed during a signal processing. The last applied action is highlighted in the 

history list (Fig. 71). 

During signal processing, you can undo changes sequentially or go back to a certain step. 

To undo changes: 

1. Click Edit > Undo/Redo. 

2. Double-click a signal processing action in the History tab. 

 
When returning to previous steps, part of the history will be lost. 

 

You can remove and return to the tab by ticking/unticking the Scheme check box in the View menu. 

When the History tab is hidden, the Filtration Scheme tab is not displayed. 

 
Figure 71: History tab. 
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15  CONFIGURING THE APPLICATION 
Most of the application settings are adjusted by default. To change the settings, click Service > Options…. 

The Options dialog will appear. 

The dialog contains the following setting controls (Fig. 72): 

 
Figure 72. Configuring the program. 

Mouse wheel zoom factor 

Specify the step to change (using mouse wheel) the size of data area (in %). 
 

Number of undo levels 

Specify the number of actions that can be undone. 

 

Please take into consideration free disk space when undoing an action, as all signal changes 
are saved to the hard disk. 
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Signal drawing 

These settings are used to adjust the signal display options. 

Select the type of signal drawing in the data area: Polyline, Stair-step, Dots. 

Specify the line thickness. 

Specify the maximum number of dots per pixel. 
 

Transcriber 

Tick the Highlight text at playback check box. During playback, text entered by the user in the Transcriber field will be highlighted. 
 

Presets 

This group of setting controls is used to adjust preset load options. 

Select the type of preset load: Filtration scheme and sound file (load a scheme with the sound file as a template), Filtration scheme (load a 

filter scheme). 
 

To save parameters, click Apply in the Options dialog. 

To close the window without saving changes, click Cancel. 
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16  FEEDBACK  
Interaction with our help desk can be simplified via the built-in module, aimed to automate the registration process, problem solving and 

error messages submission. 

If you encounter any errors or failures in the application, please contact the developers. 

To do so, click Contact us on the Help menu (Figure 73). 

 
Figure 73: Help menu options. 

Click Contact us > New error to open the Bug Reporter: New error dialog box (Fig. 74) where you can describe the error. 

The dialog appears automatically if there is a failure in the application. 

Using this dialog, you can perform the following actions: 

1. Click the Send button to send a bug report or an error message to the manufacturer (if an Internet connection is 

available). 

2. Click the Create archive button to prepare a bug report for sending. 

3. Click the Save text to write and save a message for our technical support. 

4. Click the Close button to close the dialog. 
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Figure 74: Bug reporter: Report an error dialog box. 

 

Click Contact us > New issue to open the Bug reporter: New issue dialog box (Fig. 75), where you can specify application issues. 

 
Figure 75: Bug Reporter: New issue. 

 

When you create a new error or issue description report, the Send bud report archive dialog box will appear (Fig. 76). 
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Figure 76: Sending Issue Report. 

Click Feedback > Options… to open the Bug reporter: Options dialog box (Fig. 77). Here you can customize common settings concerning 

bug report sending. 

 
Figure 77: Common bug report settings. 

 

The New error… and New issue… options become active only after supplying your email 
address in the Bug reporter - Options dialog box. 
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17  EXITING THE APPLICATION 
To exit the application: 

• Click File > Quit. 

• Click  Close in the right corner of the application header. 

• Press Alt+X on the keyboard. 

 



119 
UNINSTALLING THE APPLICATION Sound Cleaner II 

  User Guide 
 

 

18  UNINSTALLING THE APPLICATION 
To uninstall Sound Cleaner II: 

1. Open Control Panel and click Programs and Features.  

2. In the Uninstall or change a program list, select STC Sound Cleaner II, and then click Uninstall.  

3. When prompted, restart the computer. 

OR 

Uninstall the program in the menu option Start > All Programs > Speech Technology Center > Sound Cleaner II > Uninstall 

Sound Cleaner II. 
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19 APPLICATION UPDATE 
To update Sound Cleaner II, run the Setup.exe file from the STC installation disk and select installation language. A notification will appear, 

stating that Sound Cleaner II is already installed and will offer to update the program. Click Yes. 

The previous application version will be uninstalled and the installation wizard dialog will appear. To continue installation, follow the wizard 

instructions. 

 
Previously saved projects and presets will be available after the application update. 
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APPENDICES 

Appendix A: Shortcuts 
To make the application more user friendly, some actions can be performed using shortcuts. A complete list of keyboard shortcuts is available 

in the Shortcuts window (Fig. A.1). Click Shortcuts in the Help menu or press F1. 

 
Figure A.1. Application shortcuts. 
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Appendix B: Application Main Menu 
The application main menu consists of the following options: File, Scheme, Edit, View, Playback, Process, Service, Help. 

The File menu consists of the following elements: 

Open… 

Open Project… 

Save Project 

Export to Sound File… 

Create Report 

Recent Files… 

Recent Projects… 

File Info 

Close All 

Quit 

 

The Scheme menu consists of the following elements: 

Open… 

Save as… 

Clear 

Turn on All Filters 

Turn off All Filters 

Save as Preset 

Remove Preset 

Rename Preset 

 

 



123 
APPENDICES Sound Cleaner II 

  User Guide 
 

 

The Edit menu consists of the following elements: 

Undo 

Redo 

Delete 

Trim 

Divide Stereo to Two Mono 

Create Reference Channel 

Shift Signal Left 

Shift Signal Right 

The View menu consists of the following elements: 

Show Notify List 

Remove All Notifications 

Navigation Scheme 

Scheme 

In dB 

Vertical Auto-zoom 

Horizontal Auto-zoom 

The Playback menu consists of the following elements: 

Play All 

From Cursor 

Selected Area 

Pause 

Resume 

Stop 

Preview 
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The Processing menu consists of the following elements: 

Normalize 

Clip 

Resample 

Change Speed 

Filtering 
 

The Service menu consists of the following elements: 

Options… 

Copy Screen Area 

Copy Window Image 

Transcriber 
 

The Help menu consists of the following elements: 

User Guide: uses Adobe® Reader® to open this User Guide as a .pdf. 

Shortcuts: opens the list of shortcuts for convenient and fast work within the application. 

About: displays information about the application. 

Feedback: allows you to contact our Technical Support. 

Get Expert Advice: allows you to ask our experts for noise reduction service via the web site. 

Order Training: provides you with information on the training courses and enables asking our experts for advice via our web site. 

 

Working on Mac OS , the Quit Sound Cleaner II, Options… and About options are located in 

the application menu. 
 

 

To view the User Guide, install Adobe® Reader® on your PC and launch Sound Cleaner II. 

Adobe® Reader® can be downloaded from the website: http://www.adobe.com/. 

012-251014 

http://www.adobe.com/�
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